While driving car gauges suddenly sweeps

Tiny
PASHA
  • 2006 FORD FOCUS
  • 150,000 MILES

I have ford focus 2006 auto/man gear, all warning lamps came up like battery, oil, abs, hand brake, car ac cooling stop. And after few seconds everything OK but engine check lamp is on. This happened 3 times in 1 month. Checked with mechanic couldn't figure out problem. Did self diagnostic check dtc code D900, E200, E197, E510 APPEARED. Plz help

Do you
have the same problem?
Yes
No
Friday, June 22nd, 2012 AT 8:09 AM

20 Replies

Tiny
KHLOW2008
  • EXPERT
  • 42,006 POSTS

Which model Focus do you have and what engine?

Was this
answer
helpful?
Yes
No
Friday, June 22nd, 2012 AT 2:29 PM
Tiny
PASHA
  • MEMBER

Ford focus 2006 model, duratec 1.6 engine. Auto transmission and manual transmission.

Was this
answer
helpful?
Yes
No
Thursday, July 5th, 2012 AT 10:12 PM
Tiny
KHLOW2008
  • EXPERT
  • 42,006 POSTS

Our database does not have any information for your vrhicle and I could not find any reference to the codes you have posted as they are not OBD-II codes.

How did you retrieve the trouble codes?

Was this
answer
helpful?
Yes
No
Friday, July 6th, 2012 AT 1:47 PM
Tiny
PASHA
  • MEMBER

PUT KEY IN STEERING LOCK OFF AND HOLD DOWN TRIP RESET BUTTON ON INSTRUMENT PANEL. TURN IGNITION ON AND START ENGINE

. NOW CAR IS IN SELF DIAGNOSTIC MODE THAT IS TEST MODE

YOU CAN NOW CHECK IF THE CAR HAS ANY DTC CODES IN THE MEMORY.

THIS IS HOW I GOT THE CODES. THANK YOU FOR YOUR REPLY. WAITING FOR YOUR COMMENTS

Was this
answer
helpful?
Yes
No
Sunday, July 8th, 2012 AT 9:44 AM
Tiny
PASHA
  • MEMBER

Its a Ford Focus European Model

Was this
answer
helpful?
Yes
No
Sunday, July 8th, 2012 AT 9:55 AM
Tiny
PASHA
  • MEMBER

I found online today this.check this link

http://fordwiki.co.uk/index.php?title=Instrument_Cluster_Self-Diagnostic_Mode

Was this
answer
helpful?
Yes
No
Sunday, July 8th, 2012 AT 4:38 PM
Tiny
KHLOW2008
  • EXPERT
  • 42,006 POSTS

Sorry I could not find any reference to the codes you have posted even at Ford website. Get the OBD-II codes for me and I might be able to help.

Was this
answer
helpful?
Yes
No
Sunday, July 8th, 2012 AT 4:50 PM
Tiny
PASHA
  • MEMBER

D262 (U1262) Communication bus fault (missing CAN messages)
E196 (U2196) Invalid data for engine RPM (Invalid CAN message)
E197 (U2197) Invalid data for vehicle speed (Invalid CAN message)
E198 (U2198) Invalid data for fuel pulse (Invalid CAN message)
E199 (U2199) Invalid data for engine coolant temperature (Invalid CAN message)
E200 (U2200) Invalid data for odometer (Invalid CAN message)
E201 (U2201) Invalid data for ambient temperature (Invalid CAN message

may be now you can help me

Was this
answer
helpful?
Yes
No
Sunday, July 8th, 2012 AT 9:05 PM
Tiny
KHLOW2008
  • EXPERT
  • 42,006 POSTS

All these are for communication faults between the PCM and instrument cluster. Possible causes are either component could be faulty but for so many components to fail at the same time I would say it is not very likely to occur.

At the PCM and instrument cluster, check for loose or contaminated wire connectors. That would be the most likely cause.

Was this
answer
helpful?
Yes
No
Monday, July 9th, 2012 AT 3:23 PM
Tiny
PASHA
  • MEMBER

Thank you for your reply but iam getting only these codes from self diagnostic test, such as dtc code D900, E200, E197, E510
other codes I just mentioned for your reference. So from the above codes I can only know 2 codes other 2 I didn't find anywhere. Also as I had mentioned earlier that while driving car gauges suddenly sweeps, all warning lamps came up like battery, oil, abs, hand brake, car ac cooling stop. And after few seconds everything OK. Is this related to communication error or something else. May be iam troubling you too much. That you for your feedback.
E197 (U2197) Invalid data for vehicle speed (Invalid CAN message)
E200 (U2200) Invalid data for odometer (Invalid CAN message)

Was this
answer
helpful?
Yes
No
Tuesday, July 10th, 2012 AT 10:17 AM
Tiny
KHLOW2008
  • EXPERT
  • 42,006 POSTS

Sorry for the error. I thought you had a scan and that was the results. No worries about troubleing me. I am here to help and would do as best as I can.

E197 and E200 are related as the odometer requires the speed sensor to work.

D900 should be U1900 = CAN communication. Bus fault receive error. This can be due to many factors as CAN is the between the PCM and every module in vehicle. The first thing you need to do is to check for trouble codes and rectify them first if any is present. If no diagnostic trouble codes are present, you would need to check the instrument cluster. A scan tool would be required for such work as you cannot be testing each and every module and wiring which might not be related.

Try to get a scan done to see if you have any other DTC's and from the error codes you have, it could just be a faulty speed sensor or its circuit.

As to E500, I coould not find any reference for U2500 so I am not able to tell what it is. I would try the Ford website later to see if I can get anything out of it.

Was this
answer
helpful?
Yes
No
+1
Tuesday, July 10th, 2012 AT 12:49 PM
Tiny
PASHA
  • MEMBER

Thank u.I will do the required as suggested by u

Was this
answer
helpful?
Yes
No
Tuesday, July 10th, 2012 AT 4:05 PM
Tiny
DAVIDWEATHERITT
  • MEMBER

I have the exact same problem, gauges go full sweep. All dash lights go on and radio turns off. Central locking tries to lock and air blower goes off and on. Is there an answer to this problem? I heard it is a faulty Idle control valve but cant understand how this would effect all electics in this way, any help?

Was this
answer
helpful?
Yes
No
Saturday, October 6th, 2012 AT 10:55 PM
Tiny
KHLOW2008
  • EXPERT
  • 42,006 POSTS

I don't understand what the IAC has got to do with this issue. Did you check for trouble codes?

Was this
answer
helpful?
Yes
No
Saturday, October 6th, 2012 AT 11:38 PM
Tiny
DAVIDWEATHERITT
  • MEMBER

Done selt test and showing no faults. Quite strange changed battery and tried a different cluster with no joy

Was this
answer
helpful?
Yes
No
Saturday, October 6th, 2012 AT 11:58 PM
Tiny
KHLOW2008
  • EXPERT
  • 42,006 POSTS

This is a can-bus communication error and it could be due to bad control modules or loose wiring connectors. You would need a scan tool to monitor the problem and check for possible codes.

Was this
answer
helpful?
Yes
No
Sunday, October 7th, 2012 AT 12:09 AM
Tiny
DAVIDWEATHERITT
  • MEMBER

Think I have found the problem, the wire for the knock sensor is broken and touching bare metal causing a short. The car is going into garage tomorrow to get sorted anyway but do you think this could be the issue? Thanks for your help.

Was this
answer
helpful?
Yes
No
Sunday, October 7th, 2012 AT 8:53 PM
Tiny
KHLOW2008
  • EXPERT
  • 42,006 POSTS

It is possible as intermittent shorting of some control module wires can cause the control modules to go haywire.

Was this
answer
helpful?
Yes
No
Sunday, October 7th, 2012 AT 9:03 PM
Tiny
TARAGOLDSTEIN
  • MEMBER

I have the same issue going on in my 05 focus but my tail lights also go out when the others do. Please let me know what you find out. Krazylifeofmine@aol. Com

Was this
answer
helpful?
Yes
No
Monday, October 8th, 2012 AT 7:21 AM
Tiny
KHLOW2008
  • EXPERT
  • 42,006 POSTS

You should be checking anything related to the taillights which could have an intermittent shorting somewhere causing the problem. Even though the symptoms are the same, the cause could be different.

Was this
answer
helpful?
Yes
No
Please consider a donation if we helped you
Monday, October 8th, 2012 AT 10:05 AM

Please login or register to post a reply.

Related Instrument Cluster Light Questions

Recommended articles