2006 Ford Fiesta Car wont start

Tiny
THORONGA
  • MEMBER
  • 2006 FORD FIESTA
  • 1.6L
  • 4 CYL
  • TURBO
  • 2WD
  • MANUAL
  • 210,000 MILES
2006 Ford Fiesta 1.6 Tdci
after I replaced the battery, it wont start, doesnt even crank/turn. The anti theft light keeps flashing very fast. Took the car for key coding but they say the key system is ok, took the ECU for testing, but they say ECU is working 100%
help !
Do you
have the same problem?
Yes
No
Thursday, June 11th, 2015 AT 12:18 PM

5 Replies

Tiny
RACEFAN966
  • EXPERT
After some research it looks like you need to tow the car to the dealer to have the system reprogrammed so it can read the key again. For whatever reason It thinks the key is not correct. You are using a programmed key not a back up key? If so then to the dealer you go for reprogramming. Sorry no mean of you doing it yourself (anti theft system).
Was this
answer
helpful?
Yes
No
Wednesday, June 17th, 2015 AT 7:19 AM
Tiny
THORONGA
  • MEMBER
I have both the remote key and the spare plain key without the 3 buttons.
If I try to start with the remote key, the anti theft flashes very fast non stop and if I try to start with the spare key, the anti theft light just goes on, doesnt flash and doesnt switch off
But thanx for the advice, ill tow it to the dealer and hope programing the system wont be expensv
Was this
answer
helpful?
Yes
No
Thursday, June 18th, 2015 AT 5:31 AM
Tiny
RACEFAN966
  • EXPERT
Yea its the light flashing that tells me that it may have lost communication with the key and gone into theft mode. Nothing else makes sense with what I am finding so hope that's it keep me informed.
Was this
answer
helpful?
Yes
No
Thursday, June 18th, 2015 AT 7:10 AM
Tiny
THORONGA
  • MEMBER
Hi again,
so I towed the car to the dealer's workshop, and they struggled for 3 days to diagnose the problem, until they finally said my computer box was burnt.
But I don't think this technician who diagnosed my car knew what he was doing, cause I found the egr valve loose and turbo pipes loose.
Funny but now the car cranks, when I asked why it wasn't cranking, he brushed me off.
Do u think it could be the computer box?, All the car information on the cluster display is stil correct.
And the anti theft light is stil coming on, doesn't blink
Was this
answer
helpful?
Yes
No
+1
Friday, July 3rd, 2015 AT 12:16 PM
Tiny
RACEFAN966
  • EXPERT
First let me say sorry for the delay been having some real internet problems, I think it is the anti theft system that is keeping it from starting. I tend to agree with you on not knowing what he was doing why was all that messed with. So sorry about your experience with the shop should never be that way, part of the reason I do this is just that. Let me know if the car is running or not yet and I will look over the wiring diagram if not and we will go from there ok.
Was this
answer
helpful?
Yes
No
-1
Thursday, August 6th, 2015 AT 7:30 AM

Please login or register to post a reply.

Recommended Guides