Why is my temperature gauge not working and how do I fix it

Tiny
GRINDELLDELV
  • MEMBER
  • 2006 CHEVROLET SILVERADO
  • 120,000 MILES
My temperature gauge doesn't work right when I first start my truck the gauge every once in awhile reads the actual temperature which is about 210 operating temperature but then shortly after within seconds it just drops and plays dead until I turn off and then start the truck again is this the sending unit the gauge or the wiring
Do you
have the same problem?
Yes
No
Tuesday, July 17th, 2012 AT 4:23 PM

3 Replies

Tiny
ASEMASTER6371
  • EXPERT
Check the connection on the sender unit by the thermostat. Either that or the sender may be bad. If you plull the wire off, it should peg in one direction. When you ground it, it will peg in the other direction. This will test the dash unit.

Roy
Was this
answer
helpful?
Yes
No
Tuesday, July 17th, 2012 AT 4:46 PM
Tiny
GRINDELLDELV
  • MEMBER
So I need to ground the wire to the negative terminal on my battery and it should read at the hottest temperature and if it not grounded it will peg at lowest temperature and if thts the case tht means I need to replace the coolant temperature sensor
Was this
answer
helpful?
Yes
No
Tuesday, July 17th, 2012 AT 10:02 PM
Tiny
ASEMASTER6371
  • EXPERT
No, the temp sender unit. The coolant is for fuel control, not your temp gauge inside

Roy
Was this
answer
helpful?
Yes
No
Tuesday, July 17th, 2012 AT 10:30 PM

Please login or register to post a reply.

Recommended Guides