Before I ask my question I want to give a little.

  • 1 POST
  • 104,500 MILES

Before I ask my question I want to give a little background that I feel could help diagnose this problem I'm having. I have a 06' Cobalt SS Supercharged. I do have an aftermarket muffler on it. But everything else exhaust wise is stock. The other day I was driving and my car went from being loud to basically factory quiet. It did not sound like I had an aftermarket exhaust AT ALL. Also, when I accelerated to kick my supercharged in I notice I loud "whistle" or "whinning" sound that did not sound like my supercharger (I know what that sounds like). I noticed when I parked an odd oder coming from my car that I did not smell before. It wasn't overbearing or any smoke, but enough to notice. I tried starting it yesterday and it did not start. I started it today and fired right up, but same quiet exhaust. I came to the conclusion that my exhaust could be clogged or my catalytic converter is bad. What could be causing this issue? Also, I ran a diagnostic and I got a U2100 error code. I disconnected my battery to reset my ECU with no avail. Please give me some incite on what this could be. I don't want to spend a lot of money if I don'y have to. Thanks in advance.

Do you
have the same problem?
Sunday, March 3rd, 2013 AT 9:37 PM

1 Reply

  • 49,692 POSTS

The u2100 is a problem between modules. Check your fuel pressure and then check to seeif the exaust you put on is plugged or has a piece inside broken. If you hit it and hear something then try to disconnect it and see if the car starts. Also if it will run try disconnecting exaust at converter to see if it will start. If that doesn't do it haul it to a pro to look at.

Was this
Monday, March 4th, 2013 AT 12:07 AM

Please login or register to post a reply.

Recommended Guides