WHAT IS THE PROBLEM?

2005 Volkswagen Polo

Tiny

davef_1040yahoocouk

August, 8, 2012 AT 8:06 PM

I went over a speed bump earlier this evening heard a metal clank, then continued to hear the metal clank while driving.

I looked under the car and a tube/cylinder seems to be disconnected after following it, it seems to lead towards my drivers side front tyre, I don't wish to continue driving if something dangerous could happen.

FOUND 151 RELATED QUESTIONS

6 Answers

Tiny

ASEMaster6371

August, 8, 2012 AT 9:30 PM

Could be a stabalizer link or something on the lower control arm. Get it checked asap to verify it is safe

Roy

Tiny

exovcds

August, 8, 2012 AT 11:15 PM

Take a picture and post it here.

Thomas

Tiny

ASEMaster6371

August, 9, 2012 AT 12:15 AM

Glad you jumped in, Thomas

Tiny

davef_1040yahoocouk

August, 9, 2012 AT 5:41 PM

Have attached a picture, hope this helps

Tiny

exovcds

August, 9, 2012 AT 6:22 PM

Thanks for posting the picture!

We don't have the Polo here in Canada. But I attached a parts image
so you can better see the individual components.

*** I'm not 100% sure that this is the correct parts diagram for your
car. So you need to compare ***

If that rear Silver/black mount is broken (#23), then DO NOT drive the car.

The control arm is no longer mounted solid in place, and that could
cause you to lose steering!

Like ASEMaster said above, have it looked at by a Mechanic. I just
wanted to see a picture so I could say if it was still OK to drive.

A broken sway bar link for example would be OK/Safe to drive.

Can you circle the part that is broken / loose and re-post a picture?

Thomas

Tiny

exovcds

August, 9, 2012 AT 6:26 PM

I just edited your image.

Thomas

Please login or register to post a reply.

Engine Oil Change and Filter Ford Edge
 Oil Change and Filter Replacement Subaru
Engine Oil Change and Filter Saturn LS1
Engine Oil Change and Filter Replacement
Fuel Pump Pressure Test