BATTERY LIGHT FLICKERS

2005 Scion xB

Tiny

WILLIAM.SNIDER

October, 4, 2011 AT 6:02 PM

My car starts sometimes but then sometimes doesnt start. When driving in all gears my battery light flickers. I just installed a new alternator to fix the starting problem. The battery light problem just occoured with installation of the new alternator. I tested my batter and its fine. I also get a whining noise when I turn on the fan weather its heat or air its still whines. It also tries to stall more when the air is on or when the radio is turned up.

FOUND 1920 RELATED QUESTIONS

Why Is My Battery Light On?

35 ANSWERS
1 IMAGE

Gen Light

28 ANSWERS

12 Answers

Tiny

ASEMaster6371

October, 4, 2011 AT 7:47 PM

When it did not start, was the battery dead?
How did you test the battery?
Did you use a new or used alternator?
The flickering light is either a bad connection or a bad diode in the new alternator.
The whinning noise is bearings in the blower fan motor. No lube points, just replacement.
The stalling is a whole other issue. It may need a idle re learn from you having the battery disconnected or it may have other issues.

Roy

Tiny

WILLIAM.SNIDER

October, 4, 2011 AT 8:26 PM

About half the time it doesnt start so I would put it in gear and push a little and retry till it starts.
I used a volt meter and checked the correct amout of voltage a battery should be pushing and it was good.
Its a new alreanator 90 watt.
How would you do an idle re learn to see if thats the issue?

Tiny

ASEMaster6371

October, 4, 2011 AT 9:46 PM

What was the voltage? Did you mean 90 amps?

Roy

Tiny

WILLIAM.SNIDER

October, 4, 2011 AT 10:07 PM

Yea I went 90 amps and just checked the battery voltage again it's at 12.4 w/ car off

Tiny

ASEMaster6371

October, 4, 2011 AT 10:12 PM

What is it running? 12.4 is low, fully charged is 12.6

Roy

Tiny

WILLIAM.SNIDER

October, 4, 2011 AT 10:28 PM

While running it's 13.5

Tiny

ASEMaster6371

October, 4, 2011 AT 10:37 PM

Thats too low. Should be 14-14.5 volts. Is it new or used?

Roy

Tiny

WILLIAM.SNIDER

October, 4, 2011 AT 10:55 PM

It's was supposedly new when I got the car and I got it 2 months ago, when I changed the alternator on Friday autozone and o'reilys checked it and said it was good and it had the same problem but I'll head there after work and let them do it again just to see if it's that

Tiny

WILLIAM.SNIDER

October, 4, 2011 AT 11:03 PM

Autozone just said it was fine so now I have no idea at all unless it's a ground somewhere cuz I've already ran the battery cables and made sure they were fine yesterday and my belts and pullys are clean so I have no ideas what it could be

Tiny

ASEMaster6371

October, 4, 2011 AT 11:49 PM

Go over all your connections.

Please login or register to post a reply.

Alternator testing done right
Alternator Replacement Chevrolet Silverado
Alternator Replacement Ford Super Duty
Serpentine Belt Replacement Mercedes Benz
Serpentine Belt Replacement Chevrolet Tahoe
Serpentine Belt Replacement Chevrolet