2005 Mercedes Benz C240 ENGINE NOT STARTING

Tiny
AKINYEMI22
  • MEMBER
  • 2005 MERCEDES BENZ C240
  • 85,000 MILES
I have a mercedes benz 2005 c240 4matic, the engine does not roll or crank but all the lights on the dashboard light up normally but the fan also comes up rolling at a high speed. I have tried different things like removing the battery terminal but its still the same. I had it scanned but the ecu could not communicate with the scanner. I did this using three different scanners all to no avail. The ecu could not communicate with the scanners. What could be the cause of this problem
Do you
have the same problem?
Yes
No
Monday, June 17th, 2013 AT 5:55 AM

9 Replies

Tiny
KHLOW2008
  • EXPERT
Check the fuses and fusible links. A power supply is most probably missing somewhere.

The other possibility is the immobilizer is triggerred. This would result in the ECM not communicating with the scan tool. If you have a spare key with immobilizer transponder, try using it.
Was this
answer
helpful?
Yes
No
Monday, June 17th, 2013 AT 7:04 AM
Tiny
AKINYEMI22
  • MEMBER
I already used the spare key, and its still not working
Was this
answer
helpful?
Yes
No
Monday, June 17th, 2013 AT 7:10 AM
Tiny
KHLOW2008
  • EXPERT
Then you need to check for missing power supply. Have the fuses and fusible links checked.

At the Data Link Connector, test for battery voltage at terminal # 16.
Was this
answer
helpful?
Yes
No
Monday, June 17th, 2013 AT 7:14 AM
Tiny
AKINYEMI22
  • MEMBER
Hi just spoke to a friend and he said it could be the SAM signal activation module is that possible just want to confirm
Was this
answer
helpful?
Yes
No
+1
Monday, June 17th, 2013 AT 12:16 PM
Tiny
KHLOW2008
  • EXPERT
Yes, it is possibleand there are many possibilities. You should start with the basics checks instead of worrying what it could be.

Have you tested the DLC for power supply?
Was this
answer
helpful?
Yes
No
Tuesday, June 18th, 2013 AT 5:44 AM
Tiny
AKINYEMI22
  • MEMBER
I haven't tested the DLC yet, cause I don't know where its located or what it looks like. Can you please give a description of its location or a picture. That would be helpful
Was this
answer
helpful?
Yes
No
Tuesday, June 18th, 2013 AT 6:05 AM
Tiny
KHLOW2008
  • EXPERT
The DLC is the connector where you plug in the scan tool.
You had the vehicle scanned so I believe you know where it is located. You would need a DVOM to test terminal # 16 for battery voltage.
Was this
answer
helpful?
Yes
No
Tuesday, June 18th, 2013 AT 6:10 AM
Tiny
HDBXFGV
  • MEMBER
Where is the cencer on the car
Was this
answer
helpful?
Yes
No
Wednesday, September 10th, 2014 AT 10:44 PM
Tiny
KHLOW2008
  • EXPERT
What sensor are you referring to?
Was this
answer
helpful?
Yes
No
+1
Monday, September 22nd, 2014 AT 10:30 AM

Please login or register to post a reply.

Recommended Guides