Check engine light is on and the engine is shaking

Tiny
KAIS
  • 2005 MERCEDES BENZ C200
  • 60,000 MILES

C200 k mileage 61k miles suddenly extremely shaking and check engine is on and power loss, then I checked the car got cyl 2 misfire. What is the problem? The car is normal but missing a lot of power?

Do you
have the same problem?
Yes
No
Saturday, January 14th, 2012 AT 12:12 AM

24 Replies

Tiny
MHPAUTOS
  • EXPERT
  • 31,321 POSTS

Check for faulty plugs and leads and check distributor cap for cracks or if coil pack ignition have coil tested.

Was this
answer
helpful?
Yes
No
Saturday, January 14th, 2012 AT 12:22 AM
Tiny
KAIS
  • MEMBER

What is distributor cap?And where is it in engine? I am afraid when I buy plugs and coils the problem will stay? I am afraid of loosing money without pos result? Is this problem common for c200 k? Have someone faced this problem and asked you before?Was this test the answer? Thank you in advanced

Was this
answer
helpful?
Yes
No
Saturday, January 14th, 2012 AT 12:31 AM
Tiny
KAIS
  • MEMBER

I have read your replies for the same problem and you suggested the problem of missing power maybe due to bad ground and you posted the ground chart. Is that possible for my issue? Thank you again

Was this
answer
helpful?
Yes
No
Saturday, January 14th, 2012 AT 12:35 AM
Tiny
KAIS
  • MEMBER

I did a quick test, I put the transmission on n and I floored the padel I noticed the revolution does not go up more than 4000 rev even I push the padel to floor? What the sign of this what can you imply from this test? The red max rev is at 6500 rev/min

Was this
answer
helpful?
Yes
No
Saturday, January 14th, 2012 AT 12:26 PM
Tiny
MHPAUTOS
  • EXPERT
  • 31,321 POSTS

Could be fuel related, or as I said earlier a coil fault, distributor cap, leads plugs or a sensor, so I would start with a diagionstic scan as this may give a little more information on the fault.

Was this
answer
helpful?
Yes
No
Saturday, January 14th, 2012 AT 1:49 PM
Tiny
KAIS
  • MEMBER

I did scan check again and the malfunction was only air massive sensor. Also, the rate of air pressured was 10.4 when the required which is needed is 8. So what do you think about the air massive sensor? And how can I check if it is just need something to be fixed or repaired and how can I repair the air massive sensor?
Thank you in advance

Was this
answer
helpful?
Yes
No
Thursday, January 19th, 2012 AT 10:54 PM
Tiny
KAIS
  • MEMBER

If the air massive sensor reading rate is 10.4 since the required is must be 8 means the air massive sensor is defected? Can I clean it rather than buy new one since it is expensive?
Thank you again

Was this
answer
helpful?
Yes
No
Thursday, January 19th, 2012 AT 10:57 PM
Tiny
KAIS
  • MEMBER

I am sorry the malfunction reading was mass air flow sensor
thank you

Was this
answer
helpful?
Yes
No
Thursday, January 19th, 2012 AT 11:37 PM
Tiny
MHPAUTOS
  • EXPERT
  • 31,321 POSTS

You can try cleaning, but this does not always work.

Was this
answer
helpful?
Yes
No
Friday, January 20th, 2012 AT 2:17 AM
Tiny
KAIS
  • MEMBER

If the MAF sensor reading is 10.4 kg/ and the required is 8 kg/, what does it mean? Does it mean that the MAF does not work correctly and just cleaning? Or does it mean MAF is totally damaged and need new one?
Just to make sure is this rate of the air reading 10.4 is bad maf or it is just normal since the ideal rate is 8 kg/ ?
Thanks alot for your help

Was this
answer
helpful?
Yes
No
Saturday, January 21st, 2012 AT 10:43 AM
Tiny
KAIS
  • MEMBER

We found today the maf sensor missing one link since they are three very thin wires. So one advice from someone said some electrician can make that the third missing wire which is very thin just he has to make sure the wire has to be the same material of the other two links.

Is this right will this modification or repair will fix the maf sensor or will not?

Was this
answer
helpful?
Yes
No
Saturday, January 21st, 2012 AT 8:11 PM
Tiny
CADIEMAN
  • MEMBER

This wire is somewhere u need to find it its there. Then install a crimp connecter to repair. As long as the wire is the same gauge it should not matter.

Was this
answer
helpful?
Yes
No
Saturday, January 21st, 2012 AT 8:45 PM
Tiny
KAIS
  • MEMBER

We did not find it, I am woundering where did it go ! So I can understand from you that any thin metal link will be fine, because I am afraid any different size of the wire will affect the ECU since whole system is programmed for specific sizes.
Do you support me to try to put any wire to complete the MAF SENSOR wires?

The sensor is in my hand right now I have to fix it or look for some specific electrician one to do it, AM I RIGHT?
OR I HAVE TO BUY NEW ONE NOW WAY?
I would thank you very much

Was this
answer
helpful?
Yes
No
Saturday, January 21st, 2012 AT 9:38 PM
Tiny
CADIEMAN
  • MEMBER

Any copper wire the same gauge will do. But you cannot repair a wire unless you have both ends to hook back togeather.

Was this
answer
helpful?
Yes
No
Sunday, January 22nd, 2012 AT 12:00 AM
Tiny
KAIS
  • MEMBER

Even if I find the missing wire it is not guaranteed it will work correctly to make the sensor do the job perfectly why
? Because I am afraid the connection may not done correctly and the result the wire will convert high or low voltage which will cause negative effects on the control box of the car ( ECU ). SO I THINK I NEED TO BUY A NEW ONE TO AVOID ANY FUTURE PROBLEMS WHICH MAY DAMAGE THE ECU OF HUNDRED AND HUNDRED OF THOUSANDS OF DOLLARS. DO YOU AGREE WITH ME?

Was this
answer
helpful?
Yes
No
Sunday, January 22nd, 2012 AT 10:47 PM
Tiny
KAIS
  • MEMBER

Can you inform me the number of the item ( MAF SESNOR ) OF MERCEDES BENZ W203 C200 KOMPRESSOR MODEL 2004, ENIGNE 271?
I NEED THE NUMBER OF THE MAF SENSOR OF THIS CAR WHICH IS MY CAR?
THANK YOU AGAIN

Was this
answer
helpful?
Yes
No
Sunday, January 22nd, 2012 AT 10:49 PM
Tiny
KAIS
  • MEMBER

About the thin wire are you sure it is made of copper? Because the mechanic said most of these items are made of NICKEL CHROME not from COPPER ! Because you know if I put any material will damage the ECU
SO WHAT IS YOUR ADVICE IN THIS CASE?/

Was this
answer
helpful?
Yes
No
Sunday, January 22nd, 2012 AT 10:53 PM
Tiny
CADIEMAN
  • MEMBER

You need to find the missing wire and repair it. As far as the wire type. I dont no of any ecu problems being damaged. You right that, that my not be all your problems

Was this
answer
helpful?
Yes
No
Monday, January 23rd, 2012 AT 2:11 AM
Tiny
KAIS
  • MEMBER

I did not find the missing wire. What the alternative can I put?

Was this
answer
helpful?
Yes
No
Monday, January 23rd, 2012 AT 11:22 AM
Tiny
KAIS
  • MEMBER

Can you inform me about the specifications of this wire of MAF sensor of mercedes benz 2004 c200 kompressor engine 271. The part number is A 271 094 02 48

Was this
answer
helpful?
Yes
No
Monday, January 23rd, 2012 AT 11:24 AM

Please login or register to post a reply.

Recommended Guides