Lost power

Tiny
PAPADC
  • MEMBER
  • 2005 ISUZU ASCENDER
  • 6 CYL
  • 2WD
  • AUTOMATIC
2005 isuzu ascender. On long trips on interstate, car would lose some power(still runs, but little power), would be fine after a couple of minutes. Now is continual problem. Changed air filter but not much help. What should I check next?
Do you
have the same problem?
Yes
No
Tuesday, July 12th, 2011 AT 12:11 AM

13 Replies

Tiny
SATURNTECH9
  • EXPERT
I would check for codes and restricted exhaust to start with.
Was this
answer
helpful?
Yes
No
+2
Tuesday, July 12th, 2011 AT 12:18 AM
Tiny
RASMATAZ
  • MEMBER
Verify the fuel pressure and comeback with the readings-we start here
Was this
answer
helpful?
Yes
No
+1
Tuesday, July 12th, 2011 AT 12:20 AM
Tiny
PAPADC
  • MEMBER
How much of a chance could it be the catalytic converter?
Was this
answer
helpful?
Yes
No
+1
Tuesday, July 12th, 2011 AT 12:22 AM
Tiny
SATURNTECH9
  • EXPERT
I dont know odds thats why I said do a back pressure test to check for possible cat issues have it scanned for codes and checking the fuel pressure like rasmatz said wouldnt be a bad idea.
Was this
answer
helpful?
Yes
No
+1
Tuesday, July 12th, 2011 AT 12:26 AM
Tiny
PAPADC
  • MEMBER
Had it scanned last week. Only problem shown was some to do with the engine being 21% but should be around 5 or 6 %(or vice-versa). Sound familiar?
Was this
answer
helpful?
Yes
No
Tuesday, July 12th, 2011 AT 12:28 AM
Tiny
PAPADC
  • MEMBER
Old code was something to with something "below threshhold". Had it erased & it hasn't come up again
Was this
answer
helpful?
Yes
No
Tuesday, July 12th, 2011 AT 12:31 AM
Tiny
SATURNTECH9
  • EXPERT
That really doesnt ring a bell 21 percent of what?Throttle postion?Dont really know need more details about that one. How checking the fuel pressure and back pressure?
Was this
answer
helpful?
Yes
No
Tuesday, July 12th, 2011 AT 12:34 AM
Tiny
RASMATAZ
  • MEMBER
P0420

Check the Catalytic Converter if its clogged-up by doing what Sat9 suggested on backpressure test of the exhaust system-
Was this
answer
helpful?
Yes
No
Tuesday, July 12th, 2011 AT 12:34 AM
Tiny
SATURNTECH9
  • EXPERT
Would have been helpfull to have known the exact code number it was.
Was this
answer
helpful?
Yes
No
Tuesday, July 12th, 2011 AT 12:35 AM
Tiny
PAPADC
  • MEMBER
Not sure. Idles fine, doesn't skip. But when I press gas pedal a little hard, it doesn't want to go. If I ease into the gas it will evenually get to normal speed
Was this
answer
helpful?
Yes
No
Tuesday, July 12th, 2011 AT 12:38 AM
Tiny
RASMATAZ
  • MEMBER
Disable the EGR valve and see what happens might be opening too soon-don't work have the computer rescanned again -maybe something might just pop up-
Was this
answer
helpful?
Yes
No
Tuesday, July 12th, 2011 AT 12:44 AM
Tiny
PAPADC
  • MEMBER
Pretty sure the code was P0420. Was erased last week. Engine light not on again
Was this
answer
helpful?
Yes
No
Tuesday, July 12th, 2011 AT 12:45 AM
Tiny
SATURNTECH9
  • EXPERT
Without doing some testing one can only guess what might be wrong. When you do some testing let us know what you find.
Was this
answer
helpful?
Yes
No
Tuesday, July 12th, 2011 AT 12:51 AM

Please login or register to post a reply.

Recommended Guides