IDLE ROUGH

  • Tiny
  • Doubldipp
  • 2005 HYUNDAI XG350
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 90 MILES

I have a 2005 xg350gl Hyundai and I had the Timming belt changed it runs great but when idle it's kinda sputtering it doesn't cut off but it's kinda rough is that from having the belt changed and maybe it's not set right? And before I had the belt changed it was smooth.

Do you
have the same problem?
Yes
No
Wednesday, March 2nd, 2011 AT 6:26 PM

3 Replies

  • Tiny
  • Dvblove
  • MEMBER

MY 2004 HYUNDAI XG350 COMPUTER WAS REPLACE AND CONTECTED WITH WIRE TO THE FUSEBOX. AND THE SLOWS DOWN AT AT 40 MPH TO 0 THAN REPS UP AGAIN. WHATS GOING ON?

Was this
answer
helpful?
Yes
No
Sunday, May 27th, 2012 AT 7:45 AM
  • Tiny
  • Rasmataz
  • MEMBER

The valve timming could be not set correctly and also the ignition timing-what needs to done here is to put engine no.1 piston on its compression stroke/TDC and front cover remove to verify the camshaft and crankshaft positioning markings as indicated in the repair manual, if its correct now an ignition timing light is needed to set the ignition base timing as specified

Was this
answer
helpful?
Yes
No
Tuesday, July 10th, 2012 AT 11:39 PM
  • Tiny
  • Devster
  • MEMBER

I replaced spark plugs and wires for my 2002 Hyundai XG350.
It idles to 2 rpm's and when I give it gas there is no acceleration.

Was this
answer
helpful?
Yes
No
Tuesday, July 31st, 2012 AT 7:34 PM

Please login or register to post a reply.

Other Engine Runs Rough Questions