CAR WASHERS

  • Tiny
  • Trojanhorse
  • 2005 HYUNDAI TUSCON
  • 6 CYL
  • 2WD
  • MANUAL
  • 51,000 MILES

My rear and front windscreen washers have poor pressure have checked for blockages all seems ok pump moter seems to be working ok make of jeep hyundai any ideas

Do you
have the same problem?
Yes
No
Friday, February 4th, 2011 AT 9:26 AM

3 Replies

  • Tiny
  • KHLow2008
  • EXPERT
  • 41,981 POSTS

Weak pump, kinked hoses or clogged nozzles are the common causes of such problems.

Check hoses for kinking due to excessive bending or being compressed by other components.

Unplug hoses from nozzle and test the pressure, if it is good, ensure the nozzles are not clogged, usually by car wax.

Was this
answer
helpful?
Yes
No
Tuesday, February 8th, 2011 AT 1:17 PM
  • Tiny
  • Trojanhorse
  • MEMBER

Thanks for your answers I have tried blowing the pipes through with high pressure air worked for one day then stop again taking it to a garage they had the washers working but the water barly hits the bottom of the windscreen the pump seems to be working ok the garage told me some cars suffer with this problem I will just have to suck it and see thanks anyway

Was this
answer
helpful?
Yes
No
Wednesday, February 9th, 2011 AT 4:59 AM
  • Tiny
  • KHLow2008
  • EXPERT
  • 41,981 POSTS

If high pressure blasting of the hoses worked and then fail, there could be something inside the reservoir being sucked into the system and clogging it.

Was this
answer
helpful?
Yes
No
Wednesday, February 9th, 2011 AT 1:32 PM

Please login or register to post a reply.

Other General Questions