CHARGING SYSTEM

2005 Ford Taurus

Tiny

taurus8

September, 26, 2013 AT 8:15 AM

"Check charging system" light came on, found dead battery, bad alternator and a broke serpentine belt. Replaced alternator with a brand new one not rebuilt, replaced belt and battery and a found blown fuse, still receiving "check charging system" message and there is a kind of grinding sound when the A/C isn't on. Any idea what this could be or how to fix it?

FOUND 4351 RELATED QUESTIONS

My Alternator Quit Charging

22 ANSWERS
31 IMAGES

Charging System Trouble

27 ANSWERS
5 IMAGES

4 Answers

Tiny

hmac300

September, 26, 2013 AT 9:39 AM

The grinding sound may be the clutch bearing in a/c clutch. Hope you changed the tensioner as well as the belt they both should be changed. May be that too.

Tiny

taurus8

September, 26, 2013 AT 7:52 PM

Possibly but I'm not too worried about that problem at the moment and I already changed the tension pulley and idler wheel. My main concern is that the car keeps saying that the battery isn't charging even after all that. Why?

Tiny

hmac300

September, 27, 2013 AT 7:43 AM

Check the silly little fuses that's pointed out in pic. That may be your problem.

Tiny

taurus8

September, 27, 2013 AT 8:05 AM

Ha, silly little fuses. Anyways turns out that it was the whole a/c unit that went bad (even though it would still produce cold air) and it snowballed from there. Thanks for your time and help.

Please login or register to post a reply.

Alternator testing done right
Alternator Replacement Chevrolet Silverado
Alternator Replacement Ford Super Duty
Serpentine Belt Replacement Mercedes Benz ML