Why is my car stalling when I apply the breaks or put it into gear?

Tiny
JAMIE5251
  • 2005 FORD ESCAPE
  • 10,900 MILES

I have a 2005 ford escape 4 cyl 4x4. It is stalling when I apply the breaks or put it into gear but will stay running in park or neutral. Problem seems to happen after car is warmed up. It's ok as long as I apply gas and break to get the rpm's up at a stop. I replaced the throttle body and it is still doing it. Can you help me?

Do you
have the same problem?
Yes
No
Friday, June 8th, 2012 AT 5:20 PM

5 Replies

Tiny
DOCFIXIT
  • EXPERT
  • 18,988 POSTS

Faulty brake booster or vacuum check valve

Was this
answer
helpful?
Yes
No
Friday, June 8th, 2012 AT 5:22 PM
Tiny
JAMIE5251
  • MEMBER

I will try it thank you!

Was this
answer
helpful?
Yes
No
Friday, June 8th, 2012 AT 5:27 PM
Tiny
DOCFIXIT
  • EXPERT
  • 18,988 POSTS

Start with check valve

Was this
answer
helpful?
Yes
No
Friday, June 8th, 2012 AT 5:46 PM
Tiny
JAMIE5251
  • MEMBER

I had it to a machanic. They tried hooking the computer up to it but it will not read it.

Was this
answer
helpful?
Yes
No
Friday, June 8th, 2012 AT 5:50 PM
Tiny
DOCFIXIT
  • EXPERT
  • 18,988 POSTS

Booster on firewall behind brake master cylinder. See hose attached going over to engine? Valve is end of hose stuck into booster. When brakes applied vacuum is used from engine to help braking. If valve is faulty too much vacuum will leave engine and it will stall

Was this
answer
helpful?
Yes
No
Friday, June 8th, 2012 AT 6:08 PM

Please login or register to post a reply.

Other Engine Stall Questions