BMW 320D 2005 - I bought earlier this week, it.

Tiny
JEANIEWEANIE
  • 2005 BMW 320D
  • 70,000 MILES

BMW 320D 2005 - I bought earlier this week, it had been sitting up in a garage for 3-5 weeks previous. Jumped it while leaving the yard and drove home ok for about 10 miles.

Next morning woke @ 5am due to the alarm going off! Disconnected the battery and left it until later that evening, tried to start again, dead as a doe doe. Jumped the car and ran fine drove approx 70 miles and thought this would charge the battery.

Next morning up early to go to work, car wont start again, try to jump as no joy, wont even start now. Engine managment light comes on and when trying to test fuses, each and everyone are blowing :(

At the end of my tether! Where do I go from here! Help!

Do you
have the same problem?
Yes
No
Friday, March 8th, 2013 AT 12:34 PM

4 Replies

Tiny
ASEMASTER6371
  • EXPERT
  • 25,526 POSTS

Did you cross the cables when trying to jump?

Roy

Was this
answer
helpful?
Yes
No
Friday, March 8th, 2013 AT 1:24 PM
Tiny
JEANIEWEANIE
  • MEMBER

Hi Roy,

No the cables were not crossed.

Was this
answer
helpful?
Yes
No
Friday, March 8th, 2013 AT 1:45 PM
Tiny
ASEMASTER6371
  • EXPERT
  • 25,526 POSTS

For every fuse to blow, there is an electrical issue. Did the main 100 amp fuse blow?

Was this
answer
helpful?
Yes
No
Please consider a donation if we helped you
Friday, March 8th, 2013 AT 1:48 PM
Tiny
JEANIEWEANIE
  • MEMBER

No, just the smaller ones on the board

Was this
answer
helpful?
Yes
No
Friday, March 8th, 2013 AT 2:21 PM

Please login or register to post a reply.

Related Engine No Start Questions

Recommended articles