CAR

2004 Nissan Maxima

Tiny

dhornb1

August, 31, 2012 AT 5:24 PM

My '04 Nissan Maxima overheats only when at idle, the temp drops back to normal when car is moving. Also, I just noticed that the a/c doesnt blow cold air while at idle either. It blows cold once the car is moving.

.I'm thinking that the 2 problems are being caused by either a bad fan motor or bad fan motor fuse. Is it most likely that or could it be something else?

Thanks for your help!

FOUND 6257 RELATED QUESTIONS

No Heat

37 ANSWERS
5 IMAGES

6 Answers

Tiny

KHLow2008

August, 31, 2012 AT 5:59 PM

Check the cooling fans first. Both should come on with the A/C turned on and compressor running.

Ensure there are sufficient coolant in the radiator and you do not have coolant losses.

Tiny

dhornb1

August, 31, 2012 AT 6:07 PM

I havent looked at it yet but I believe there are 2 fans. Is there 1 fuse for both fans or does each fan have their own fuse?

(I assume if one one fan is turning then I have a bad fan motor on one).

Tiny

KHLow2008

August, 31, 2012 AT 6:14 PM

They are 2 different circuits and work independent of each other. Have a look first.

Tiny

dhornb1

August, 31, 2012 AT 6:15 PM

Oops sorry for the typo.I meant to say that I assume if only one fan is turning then I have a bad fan motor on the other one.

Tiny

dhornb1

August, 31, 2012 AT 6:16 PM

Oh ok, thanks!

Tiny

KHLow2008

August, 31, 2012 AT 6:55 PM

You need test to confirm if it is a fan or other issues.

Please login or register to post a reply.

Cabin Air Filter Replacement Saturn Vue
Cabin Air Filter Replacement Chevrolet Tahoe
Cabin Air Filter Replacement
Cabin Air Filter Replacement
Cabin Air Filter Replacement