Engine started shutting off

Tiny
NICHOLASJ234
  • 2004 MAZDA 6
  • 99,000 MILES

I drive a 2004 Mazda 6, 4 cyl with 99000mi about a month ago it started shutting off when I came to a stop, I took it to the shop the cleaned the throttle body but it didn't stop, took it back to them and a week later they said they have no idea. I checked the hoses and they are good, the problem has gotten worse, now in addition to the shutting off, when I accelerate the rpm's bounce way down a couple times before it will take off and it does this in about every gear. I am deploying soon and I really don't want to leave my wife with this problem any help is greatly appreciated :-)

Do you
have the same problem?
Yes
No
Thursday, January 26th, 2012 AT 4:35 PM

5 Replies

Tiny
HMAC300
  • EXPERT
  • 45,785 POSTS

Scan for codes and check fuel pressure first. Check the vacuum at intake and if below 15" @idle check for plugged converter

Was this
answer
helpful?
Yes
No
Thursday, January 26th, 2012 AT 8:25 PM
Tiny
NICHOLASJ234
  • MEMBER

I checked all hoses and there are no codes?

Was this
answer
helpful?
Yes
No
Thursday, January 26th, 2012 AT 8:42 PM
Tiny
HMAC300
  • EXPERT
  • 45,785 POSTS

Re read the first reply

Was this
answer
helpful?
Yes
No
Thursday, January 26th, 2012 AT 8:43 PM
Tiny
NICHOLASJ234
  • MEMBER

Gotcha sorry, is that this black small square thing on the the intake, tube.

Was this
answer
helpful?
Yes
No
Thursday, January 26th, 2012 AT 8:59 PM
Tiny
HMAC300
  • EXPERT
  • 45,785 POSTS

Ideally if you can connect the vacuum gauge to where I have the arrow pointing inthe picture would be best. Hopefully this is the correct engine I have sent you.

Was this
answer
helpful?
Yes
No
Friday, January 27th, 2012 AT 12:26 AM

Please login or register to post a reply.

Other Engine Stall Questions