HEATER BLOWER QUIT WORKING ON ALL SPEEDS

2004 Kia Amanti

Tiny

gholt

December, 18, 2012 AT 12:44 AM

Heater blower quit working on all speeds. Just like a 2010 question you answered. I replaced the blower transistor. Still no go. Checked voltage at transistor- OK. Switch-OK, checked voltage at blower-OK. Removed blower and hooked it up direct to DC and it works fine. Checked high speed relay-good. Fuse-good. Don't know what else to check. Any suggestions?

FOUND 795 RELATED QUESTIONS

Rear Blower Not Working

16 ANSWERS
9 IMAGES

7 Answers

Tiny

saturntech9

December, 18, 2012 AT 12:55 AM

Do you have a multi meter to do some testing?If there is power at the motor then you have a bad ground feed to the motor or loose/bad connection at the connector?

Tiny

gholt

December, 18, 2012 AT 11:10 PM

Yes, I do have a multi meter and I have checked the voltage coming through the plug to the blower motor. Getting 8-12 volts depending on speed of fan selected.

Tiny

saturntech9

December, 19, 2012 AT 1:33 AM

Alright what about the ground side?Or are you measuring voltage across the two terminals?

Tiny

gholt

December, 19, 2012 AT 11:31 PM

I am measuring the voltage across pins 1 & 2. As I understand it this is the ground and positive.

Tiny

saturntech9

December, 19, 2012 AT 11:54 PM

If your getting 8-12 volts across the pins then the motor should work unless there is a bad connection some where.

Tiny

gholt

December, 20, 2012 AT 1:25 AM

OK, thanks. I'll have it checked out.

Tiny

saturntech9

December, 20, 2012 AT 2:59 AM

Your welcome keep me posted.

Please login or register to post a reply.

Blend Door Actuator Replacement
Air Conditioner Condenser Fan Relay Replace
Air Conditioner Recharge - Simple
Cabin Air Filter Replacement