I REPLACED THE WATER PUMP AND TIMMING BELT.

2004 Holden Rodeo

Tiny

Kai tippett

December, 30, 2011 AT 1:49 AM

Holden rodeo 3.5 v6 Now when you start the engine it ticks over normally but as soon
As you tap the pedal it pops though the air box.
Also when you unplug the coil pack on the left side nothing happens as if this side is not firing.
So I unplugged the right side and the car starts on the left side for a split second then cuts off.
I've checked all plugs and coil pack have a spark, done a compression test and all is ok.
I need help!
Regards Kai.

FOUND 2595 RELATED QUESTIONS

4 Answers

Tiny

cadieman

December, 30, 2011 AT 2:06 AM

Youll need to check the engine timing marks 1 is off the mark.

Tiny

Kai tippett

December, 30, 2011 AT 3:45 AM

Hi ya! I've just re-lined the timing lines and Is still doing the same. Is there any other thing that would cause this problem?
Regards kai

Tiny

cadieman

December, 30, 2011 AT 7:43 PM

Engine ticks? Lifter tap?Replace the coil pack. Use a test light to probe the wires. Youll know what is getting spark or voltage. Their cheap but handy tool.

Tiny

Kai tippett

January, 5, 2012 AT 12:27 AM

Hi ya!
I've checked the timing Marks and they are all perfect, done compression test, all are exactly the same about 210 psi. I've got a spark on all plugs. And still have the same problem. The car starts fine, idles fine, but as soon as you touch accelerator the car backfires though the air box.
Kai

Please login or register to post a reply.

Water Pump Replacement Made Easy
Heater Hose Replacement Chevrolet Camaro
Serpentine Belt Replacement Chevy 1500
Serpentine Belt Replacement Mercedes Benz ML
Serpentine Belt Replacement Mercedes Benz
Serpentine Belt Replacement Acura MDX