What is the problem help me

Tiny
PUNISH19
  • MEMBER
  • 2004 CHRYSLER TOWN AND COUNTRY
  • 95,000 MILES
Its misfiring and I have no power, changed plugs and wires and coil pack, code is p0300 and p0306 in desperate need here thank you
Do you
have the same problem?
Yes
No
Monday, September 19th, 2011 AT 9:01 PM

12 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Check for plugged catalytic converter, check fuel pump pressure, if the check engine light is on, have the computer scanned for trouble codes. Most parts stores will do it for free.
Was this
answer
helpful?
Yes
No
+1
Tuesday, September 20th, 2011 AT 12:56 AM
Tiny
PUNISH19
  • MEMBER
The light is on and I have the codes but they can't tell me what exactly is wrong first it was misfire cylinders 1 and 3 now its cylinders 1 and 6 I don't get it.
Was this
answer
helpful?
Yes
No
Tuesday, September 20th, 2011 AT 3:04 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Wow. That makes it difficult because many things can cause a misfire. When was the last tune up? Have you ever tried fuel injection cleaner? Have you checked fuel pump pressure? Has anyone checked the crank sensor?
Was this
answer
helpful?
Yes
No
-1
Tuesday, September 20th, 2011 AT 3:21 AM
Tiny
PUNISH19
  • MEMBER
Injector cleaner didn't work I changed spark plugs and wires and the coil pack, how do I check fuel pressure and could it be bad injectors or not.
Was this
answer
helpful?
Yes
No
Tuesday, September 20th, 2011 AT 8:52 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
To check fuel pump pressure, go to our homepage under the DIY section. There is a video and directions. As far as an injector, sure. If it isn't firing fuel correctly, it will cause a miss. However, it is odd that it is changing cylinders.
Was this
answer
helpful?
Yes
No
Wednesday, September 21st, 2011 AT 1:51 AM
Tiny
PUNISH19
  • MEMBER
I have heard the EGR valve can cause it to misfire at different times the code that comes up is p0300
Was this
answer
helpful?
Yes
No
Wednesday, September 21st, 2011 AT 2:16 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Yes, the egr can. THe PO300 is a general code for multi cylinder misfire. Check the EGR. Check for carbon build up in both the intake and EGR valve itself. If clean, see if the plunger moves when vacuum is applied and make sure the valve has a clean full seat when closed.
Was this
answer
helpful?
Yes
No
Wednesday, September 21st, 2011 AT 2:36 AM
Tiny
PUNISH19
  • MEMBER
Ok new development my engine light went off for about an hour and the van ran so much better but my battery connection got loose and almost came off as soon as I fixed that the light popped back on and started running bad again what's ur thoughts?
Was this
answer
helpful?
Yes
No
Thursday, September 29th, 2011 AT 11:50 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Was the battery disconnected?
Was this
answer
helpful?
Yes
No
Thursday, September 29th, 2011 AT 6:12 PM
Tiny
PUNISH19
  • MEMBER
No it was really loose thou cuz I put a new battery in last week
Was this
answer
helpful?
Yes
No
Thursday, September 29th, 2011 AT 7:53 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Make sure the wiring from the battery to the fuse box is in good condition.
Was this
answer
helpful?
Yes
No
Thursday, September 29th, 2011 AT 10:33 PM
Tiny
PUNISH19
  • MEMBER
I found the problem spark plug 1 gap was closed completely and spark plug 6 had a cracked porcelain in it thanks for the help thou
Was this
answer
helpful?
Yes
No
Monday, October 3rd, 2011 AT 3:33 PM

Please login or register to post a reply.

Recommended Guides