Toyota stalls at low speeds

Tiny
CLASSICIST2001
  • MEMBER
  • 2003 TOYOTA SOLARA
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 130,000 MILES
I drive Toyota Camry Solara 2003, 130,000 miles on the car. In the last month, the car stalled twice. Both times, I was driving at very low speeds, pulling out of a parking space or making a U-turn in the parking lot. In both cases, I put the car in park and then restarted it. Also, there is some engine trembling or vibration at low speeds, especially when the air conditioner is on. I replaced the oxygen censor on the car a year ago. Is the oxygen censor the same as EGR valve? What can cause this probl? Thank you for your help!
Do you
have the same problem?
Yes
No
Wednesday, February 23rd, 2011 AT 5:08 PM

6 Replies

Tiny
KHLOW2008
  • EXPERT
No, O2 sensor and EGR are 2 different things.

Symptoms indicates a fault with the idle control system and engine is stalling due to too low idling rpm.

If the Check Engine Light is not indicating, get the throttle body and Idle Air Conltrol valve cleaned and retest.
Was this
answer
helpful?
Yes
No
+1
Wednesday, February 23rd, 2011 AT 9:17 PM
Tiny
CLASSICIST2001
  • MEMBER
Thank you. The check engine light does not turn on, indicating that there is a problem. Will hooking up a diagnostic computer give the codes as to what the problem is?
Was this
answer
helpful?
Yes
No
Thursday, February 24th, 2011 AT 1:05 AM
Tiny
KHLOW2008
  • EXPERT
If there are any trouble codes stored, a scan tool would tell you the circuit that is affectig it.

Do you mean the CEL is not indicating at all, even when ignition switch is turned on before starting?

When engine is running and the CEL comes on, it indicates an error/fault has been detected.
Was this
answer
helpful?
Yes
No
Thursday, February 24th, 2011 AT 12:49 PM
Tiny
CLASSICIST2001
  • MEMBER
What I meant to say, there is no engine light on when the car is running. When I turn the ignition switch on before starting, the CEL light comes on. Every time the car stalled, all lights on the dashboard came on (CEL light, battery light, etc). I will go to a local parts store and see if they can hook up a scan tool to see if there are any trouble codes stored and then will take it for throttle body cleaning and Idle Control Valve adjustment. Hopefully, this will do the trick. Once again, thank you for your help.
Was this
answer
helpful?
Yes
No
Thursday, February 24th, 2011 AT 3:50 PM
Tiny
KHLOW2008
  • EXPERT
If the CEL is not indicating while running, it means the system is not detecting any faults so most likely there would be no trouble codes.

Cleaning the throttle body and IAC to stabilise the idling speed should resolve the problem.
Was this
answer
helpful?
Yes
No
Thursday, February 24th, 2011 AT 11:25 PM
Tiny
CLASSICIST2001
  • MEMBER
Thank you very much for taking time to answer my questions. I will do just that.
Was this
answer
helpful?
Yes
No
+1
Friday, February 25th, 2011 AT 2:24 AM

Please login or register to post a reply.

Recommended Guides