CAR WOULD NOT ACCELERATE

  • Tiny
  • Heartlandbeauty
  • 2003 SATURN L300
  • 77,000 MILES

Today was an extremely humid and hot day in WI. After seven minutes of my car running on my way home from work, on the high way my car started to slow down without me even touching the brake. I had tried to acelerate and my car would not increase its speed! It began to shake and slow down even more. I luckily pulled my car to the side of the high way and it would NOT start. The battery light, check engine light, and oil light all came on. ( I recently had my oil changed by an expierenced friend days ago and my car ran fine). I had my car towed to the shop, but they only have one saturn tech that works in the area! Two months ago I had the crank shaft position sensor replaced. What could this be? I'd appreciate any answers! I am a 21 year old barely affording this car the way it is!

Do you
have the same problem?
Yes
No
Thursday, July 21st, 2011 AT 1:03 AM

14 Replies

  • Tiny
  • Saturntech9
  • EXPERT
  • 30,228 POSTS

Did the battery light etc come on while the engine was running or after the engine died?Also when you tried to restart the car did it crank no start or no crank no start?Also if you could get me any trouble codes that are in the computer that would really help also.

Was this
answer
helpful?
Yes
No
Thursday, July 21st, 2011 AT 1:18 AM
  • Tiny
  • Heartlandbeauty
  • MEMBER

I honeslty don't remember if it did while it first happened. I know I tried to start the car and it would not start; well it did for a minute then died off. When I turned the key the battery light, engine light, and oil lights were on. I don't know of any codes. Sadly they cannot even look at my car until tomorrow.

Was this
answer
helpful?
Yes
No
Thursday, July 21st, 2011 AT 1:31 AM
  • Tiny
  • Heartlandbeauty
  • MEMBER

No crank no start says my father who was there. The tow operator thought it was a charging problem or dead battery.

Was this
answer
helpful?
Yes
No
Thursday, July 21st, 2011 AT 1:33 AM
  • Tiny
  • Saturntech9
  • EXPERT
  • 30,228 POSTS

Thats why I asked if the battery light came on while the engine was running to see if we need to suspect a charging issue. If it wont crank then we could suspect a battery/charging issue or locked up engine.I doubt the starter died the same time the engine did. Without you being able to do some testing since the car is at the shop I dont know how much help I can be to you right now. Keep me posted and I will give you my advice.

Was this
answer
helpful?
Yes
No
Thursday, July 21st, 2011 AT 1:42 AM
  • Tiny
  • Heartlandbeauty
  • MEMBER

Well I know I pushed the gas pedal to the floor and it didn't go anywhere. I appreciate your help! I don't know much about cars at all! I wanted some sort of an idea. I truly hope that a charging issue or locked up engine won't cost too much.

Was this
answer
helpful?
Yes
No
Thursday, July 21st, 2011 AT 1:46 AM
  • Tiny
  • Saturntech9
  • EXPERT
  • 30,228 POSTS

Well a charging issue wouldnt be too bad but a locked up engine would mean the engine siezed and wont turn over freely. Did you ever check the oil level of the car when it died?

Was this
answer
helpful?
Yes
No
Thursday, July 21st, 2011 AT 1:51 AM
  • Tiny
  • Heartlandbeauty
  • MEMBER

I did not. I had it changed less than a week ago. I guess I should have checked that.

Was this
answer
helpful?
Yes
No
Thursday, July 21st, 2011 AT 1:55 AM
  • Tiny
  • Saturntech9
  • EXPERT
  • 30,228 POSTS

Yeah you should have keep me posted and I will help you out the best I can.

Was this
answer
helpful?
Yes
No
Thursday, July 21st, 2011 AT 2:17 AM
  • Tiny
  • Heartlandbeauty
  • MEMBER

I will do so! Thanks for the help!

Was this
answer
helpful?
Yes
No
Thursday, July 21st, 2011 AT 2:19 AM
  • Tiny
  • Saturntech9
  • EXPERT
  • 30,228 POSTS

Your welcome talk to you soon.

Was this
answer
helpful?
Yes
No
Thursday, July 21st, 2011 AT 2:44 AM

Please login or register to post a reply.

Other Engine Low Power Questions