Windshield wipers quit working

Tiny
CJCODY66
  • MEMBER
  • 2003 JEEP LIBERTY
  • V6
  • 2WD
  • AUTOMATIC
  • 134,000 MILES
The radio and front wiper quit working, fuses and relays are all good. Two days later no power locks and speedometer no longer works. We have no clue what it wrong. Does anyone know?
Do you
have the same problem?
Yes
No
Tuesday, August 12th, 2014 AT 10:01 AM

9 Replies

Tiny
JDL
  • EXPERT
I have not looked at your wiring, yet. Just pick one system, check applicable fuse for voltage, use a test light. Some fuses are hot all the time, some go hot with the key on.

Any applicable trouble codes? Will the vehicle start and run? Some of the national brand auto stores will check codes for free.
Was this
answer
helpful?
Yes
No
+1
Tuesday, August 12th, 2014 AT 10:30 AM
Tiny
JDL
  • EXPERT
The diagram is for base radio. Check the fuse circuit for voltage, One fuse circuit is hot all the time, the other goes hot with the key on.
Was this
answer
helpful?
Yes
No
Tuesday, August 12th, 2014 AT 10:41 AM
Tiny
CJCODY66
  • MEMBER
My vehicle does run and we did use a test light, and I had the code tested and all it said was speed control sensor.
Was this
answer
helpful?
Yes
No
Tuesday, August 12th, 2014 AT 10:52 AM
Tiny
JDL
  • EXPERT
Title of your post said fuse problem. Are you saying you have voltage at the applicable fuses?
Was this
answer
helpful?
Yes
No
Tuesday, August 12th, 2014 AT 11:02 AM
Tiny
CJCODY66
  • MEMBER
Yes, we have power to everything, but nothing works.
Was this
answer
helpful?
Yes
No
Tuesday, August 12th, 2014 AT 12:07 PM
Tiny
JDL
  • EXPERT
If the component has good voltage and good ground, maybe the component is faulty? If the bcm has control over those components, then check the BCM.

If the speedometer does not work, then check the vehicle speed sensor, where applicable.
Was this
answer
helpful?
Yes
No
Wednesday, August 13th, 2014 AT 2:30 PM
Tiny
KELCATZEYE
  • MEMBER
  • 2004 JEEP LIBERTY
The wipers are not working properly. The "Hi" and "Low" both work, but when I put it on any of the delay positions, the wipers stick and try to move. Any ideas? Not sure if it is the wiper arm switch or something more.

Thank you!
Was this
answer
helpful?
Yes
No
+1
Thursday, January 5th, 2017 AT 5:55 PM (Merged)
Tiny
JASON0665
  • MEMBER
  • 2006 JEEP LIBERTY
  • 63,000 MILES
The rear wiper will not work, because there was heavy snow on it and I turned the wiper on to clear the window. Now seems like it will not stay in the right area. Anyway to reset it back to factory?
Was this
answer
helpful?
Yes
No
Thursday, January 5th, 2017 AT 5:55 PM (Merged)
Tiny
RASMATAZ
  • MEMBER
The wiper arm could be stripped out.
Was this
answer
helpful?
Yes
No
Thursday, January 5th, 2017 AT 5:55 PM (Merged)

Please login or register to post a reply.

Recommended Guides