BEFORE I ORDER A REPLACEMENT MOTOR 401063 I WAS ...

  • Tiny
  • Jmsg2112
  • 2003 HUMMER H2
  • 85,000 MILES

Before I order a replacement motor (40-1063), I was wondering if the problem really might be elsewhere. It appears as though the wiper motor is running fine no strange noises, blade arms work, intermittent works, high and low work but everything appears to have reversed, ie. When I turn off the wiper dial on the arm, the blades stop and set in an up position on the windshield. See attached image

Do you
have the same problem?
Yes
No
Thursday, December 27th, 2012 AT 5:19 PM

3 Replies

  • Tiny
  • Saturntech9
  • EXPERT
  • 30,239 POSTS

So the wipers work perfect but when you turn them off they stop in the middle of the windshield instead of the base of the windshield?That's usually caused by a bad wiper motor/ logic board.

Was this
answer
helpful?
Yes
No
Thursday, December 27th, 2012 AT 5:28 PM
  • Tiny
  • Jmsg2112
  • MEMBER

Yes, when I turn the wipers off from the signal arm dial, they set in the position as seen in the photo, kind of like when you turn your car off and they are mid wipe, when you kill the power they stop on the windshield. I can replace the motor ( I purchased one anyway ) despite the fact that it is working mechanically sound, it is the response about a logic board that I have no knowlege of, I've searched to web since reading your response and cannot find anything on a 2003 H2 logic board, please advise further if you would

Was this
answer
helpful?
Yes
No
Thursday, December 27th, 2012 AT 6:04 PM
  • Tiny
  • Saturntech9
  • EXPERT
  • 30,239 POSTS

The logic board is on the motor itself I was trying to find a trouble tree for wipers not parking for that vechile. But was unable to find one its usually the wiper motor/logic board that causes that though.

Was this
answer
helpful?
Yes
No
Friday, December 28th, 2012 AT 6:30 AM

Please login or register to post a reply.

Other Windshield Wiper Motor Noise Questions