RAN FINE WENT IN STORE AND WHEN I CAME OUT CAR ...

2003 Chevrolet Suburban

Tiny

supasmooth76

November, 26, 2012 AT 2:28 AM

Ran fine, went in store and when I came out car started but ran rough for a minute then died. I listened for fuel pump and it didn't come on. I replaced the pump and filter and still won't start. I borrowed a code reader and it had p0300. Rented a fuel pressure gauge and it didn't register any pressure. I hooked it up before and after the fuel filter with no reading but when I unhooked the fuel lines fuel comes out at a decent rate. I checked fuses and grounds and all were good. When I try and look online there is a dozen things people say it could be. I'm looking for a priority order of things it could be. Any help is greatly appreciated. Thank you in advance.

4 Answers

Tiny

ASEMaster6371

November, 26, 2012 AT 3:16 AM

Check for power to the pump. The original pump may have blown the fuse as well.

Roy

Tiny

supasmooth76

November, 26, 2012 AT 4:13 AM

Thanks for the response. There is power to the pump, I haven't checked with a meter but it pumps fuel up to the pressure regulator but dies after a few seconds.

Tiny

ASEMaster6371

November, 26, 2012 AT 11:55 AM

What is the exact pressure?

Roy

Tiny

supasmooth76

November, 26, 2012 AT 2:45 PM

It registered zero on the gauge. When hooked up to the pressure relief valve it won't jump up to 5 psi when cracking the key but fall back to zero after a second but what confuses me is fuel would pump out if I unhooked the line.

Please login or register to post a reply.

Fuel Filter Change
Fuel Pump Replacement Done Right
Fuel Pump Replacement
Fuel Filter Replacement Chevrolet Silverado
Fuel Filter Replacement Chevrolet Silverado
Fuel Filter Replacement Ford Escape 2000-2006
Fuel Filter Replacement Ford Mustang