2003 Chevrolet Monte Carlo Anti-lock Brake and traction control

Tiny
TAMARA72
  • MEMBER
  • 2003 CHEVROLET MONTE CARLO
  • 6 CYL
  • AUTOMATIC
  • 185 MILES
When we start the car the traction control light says it's off and the Anti-lock brake message comes on. And I do not know what could be wrong with my car. Also when I brake when I am driving I push on the brakes it feels like it is pushing back against my foot. Also while driving this noise comes from the front of the car. Do you know what any of these might be.
Do you
have the same problem?
Yes
No
Wednesday, September 3rd, 2014 AT 5:13 PM

1 Reply

Tiny
CARADIODOC
  • EXPERT
The noise can be anything from worn out brakes that are grinding to the normal sound of the anti-lock system activating, but when it's not called for. Given that GM has had a real big problem with their front wheel bearings causing false ABS activation, those are the likely suspects. The wheel speed sensors develop real wimpy signals to start with, then the normal play that occurs in the wheel bearings causes even weaker signals to be generated until the point when the computer can't see them. At that point it thinks that wheel stopped rotating and it needs to try to stop it from skidding.

Electrically the speed sensors are still okay so no diagnostic fault code may be set related to that, but since the yellow warning light is on, there will be some other fault code in that computer. You'll need to find a mechanic with a scanner that can access that computer to see what the fault code says. It will indicate the circuit or system that needs further diagnosis, or the unacceptable operating condition.
Was this
answer
helpful?
Yes
No
Wednesday, September 3rd, 2014 AT 5:28 PM

Please login or register to post a reply.

Sponsored links