DASH LIGHTS BLINK ON AND OFF THEN ENGINE STALLS

2003 Buick Regal

Tiny

mulliganstein

August, 11, 2012 AT 3:47 PM

03 Buick Regal. Stalled the other day and when I tried to start it, the dash lights flashed on and off repeatedly and the engine revved in time with the dash lights until it stalled (same tempo as if I'd turned the emergency hazards on).
When I did turn the hazard lights on, the car started and ran fine. Turned hazards off. Dash lights and engine did the same thing until it stalled again.
I tried disconnecting the fuse for hazards and it ran ok for awhile then stalled and flashed again.
It seems to be ok in either case when idling but when it's in drive and trying to move, the trouble starts.
Any ideas as to what might be causing this?

FOUND 2655 RELATED QUESTIONS

14 Answers

Tiny

KHLow2008

August, 11, 2012 AT 3:50 PM

Symptoms indicate a possible loose ground connection somewhere.

Tiny

mr onsite

August, 11, 2012 AT 4:01 PM

I would check the battery connection first.

Tiny

mulliganstein

August, 11, 2012 AT 10:06 PM

Yeah, battery was replaced a, month ago and is fine. Can't seem to find any bad grounds.
I took the PCM out and banged on it while the car was idling and nothing happened.
I've also read about a possible bad ignition switch is that worth a look?
Also where is the BCM on this car?

Tiny

mr onsite

August, 11, 2012 AT 11:02 PM

Did the problem began after the battery was replaced or before?

Tiny

mulliganstein

August, 11, 2012 AT 11:41 PM

The new battery was in for a month or two and everything was fine. The problem just started a couple days ago.
I found this video on Youtube my car is doing the same thing only mine stops when you turn on the hazards not the turn signals.

http://www.youtube.com/watch?v=NSjnagtYQ7g

Thanks

Tiny

mr onsite

August, 12, 2012 AT 2:38 AM

I would call the dealerships service department and describe the problem to them, to see if they have any recall. It could be the multifunction switch creating the whole problem or the ignition switch itself.
Good luck.

Tiny

KHLow2008

August, 12, 2012 AT 8:30 AM

Vehicle is equipped with BCM and it is possible that is the cause.
Get a scan done to check for trouble codes.

Tiny

mulliganstein

August, 12, 2012 AT 12:54 PM

Where is the BCM located on this car? It's not in my haynes manual.
Thanks

Tiny

mulliganstein

August, 12, 2012 AT 1:00 PM

P.S> I did a scan. Got some ABS problems and an O2 sensor problem.

Tiny

KHLow2008

August, 12, 2012 AT 2:20 PM

BCM is behind left side of dash, left of steering column. It could be the ignition switch as per the link you gave as the hazard lights and turn signals are related.

Near steering column there are 2 gdounding points, check those as they are for the BCM.

Please login or register to post a reply.

Instrument Cluster Replacement GMC Yukon