Speedometer not working

Tiny
AFPGARY
  • MEMBER
  • 2002 VOLVO S40
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 110,000 MILES
Speedometer not working comes back once in a while for a few minutes but not too often.
Do you
have the same problem?
Yes
No
Wednesday, December 15th, 2010 AT 3:59 PM

7 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Is the transmission shifting properly?
Was this
answer
helpful?
Yes
No
+1
Tuesday, December 28th, 2010 AT 5:00 AM
Tiny
AFPGARY
  • MEMBER
Yes the car seems to be operating properly and driving properly.
Was this
answer
helpful?
Yes
No
Wednesday, December 29th, 2010 AT 12:44 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
If that is the case, then the vehicle speed sensor is working fine. The next issue would be the speedo iteself. It could be defective or something as simple as a bad ground.
Was this
answer
helpful?
Yes
No
Wednesday, December 29th, 2010 AT 6:14 PM
Tiny
AFPGARY
  • MEMBER
I am currently working on it being an electrical issue. I also have a ABS light and a brake light on. They came on about the same time the speedo stopped working. Just a lot of wires to trace and I have not been able to find a wiring diagram much less a service manual.
Was this
answer
helpful?
Yes
No
Thursday, December 30th, 2010 AT 7:46 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Interesting the ABS light came on. Have you had the computer scanned to identify which sensor turned it on? As far as the schematics, give me specific locations you are working with and I'll try to get them for you.

Joe
Was this
answer
helpful?
Yes
No
Thursday, December 30th, 2010 AT 8:50 PM
Tiny
AFPGARY
  • MEMBER
I had volvo scan the computer and they said the computer was not communicating with the ABS module. At this point I am thinking whatever is causing the speedo to drop out is also causing the ABS light to come on. I have not been able to find that the two have anything in common so I think the wires may bedamaged some were. The problem use to come and go but now it has been locked in for the last week or so. I did see on another site that someone had the same problem with the same make, modle and year car about a year ago but there was nothing posted as to what was found. I tried to email back but have not received a reply.
Was this
answer
helpful?
Yes
No
Monday, January 3rd, 2011 AT 5:14 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Check wiring and to the VSS.

Let me know what you find.

Joe
Was this
answer
helpful?
Yes
No
Monday, January 3rd, 2011 AT 6:13 PM

Please login or register to post a reply.

Recommended Guides