Noise in upper engine

Tiny
WEAVERDAD
  • MEMBER
  • 2002 VOLKSWAGEN PASSAT
  • 4 CYL
  • 2WD
  • MANUAL
  • 170,000 MILES
I have a 2002 VW Passat 1.8T w/170xxx miles. Car starts great but has a tapping in upper engine. I drive it for about 10-15 seconds and CEL and oil light comes on and it loses power. A coil pack is bad for sure. Can this cause noises and oil lights to come on? And can you have a total loss of oil pressure then regain it later?
Do you
have the same problem?
Yes
No
Monday, January 3rd, 2011 AT 3:41 PM

10 Replies

Tiny
MHPAUTOS
  • EXPERT
The coil pack will not cause low oil pressure, you will have to get the pressure tested with a mechanical gauge to check true pressure, a faulty pressure relief vale can cause this loss and gain in pressure.

Mark (mhpautos)
Was this
answer
helpful?
Yes
No
Monday, January 3rd, 2011 AT 3:47 PM
Tiny
WEAVERDAD
  • MEMBER
Would/could the bad valve be the cause of the noise? Does it possibly need a total new engine?
Was this
answer
helpful?
Yes
No
Monday, January 3rd, 2011 AT 3:56 PM
Tiny
MHPAUTOS
  • EXPERT
Get the pressure tested with a mechanical gauge, the mechanic can normally tell by watching the readings if the relief valve is faulty, get this done first.

Mark (mhpautos)
Was this
answer
helpful?
Yes
No
Monday, January 3rd, 2011 AT 4:07 PM
Tiny
WEAVERDAD
  • MEMBER
What happens is the oil pressure is ok at first then after it warms up a light comes on and says "Low oil pressure stop engine" then after you turn it off it goes off and doesn't come back on until it idles for 10-15 mins. It doesn't lose and gain pressure while driving.
Was this
answer
helpful?
Yes
No
Monday, January 3rd, 2011 AT 4:18 PM
Tiny
MHPAUTOS
  • EXPERT
We need to eliminate any possibility of pump or relief valve problem, with the test as mentioned, second guessing is just not going to help, do the test first.

Mark (mhpautos)
Was this
answer
helpful?
Yes
No
Monday, January 3rd, 2011 AT 11:16 PM
Tiny
WEAVERDAD
  • MEMBER
Ok replaced the coil pack and engine noise is better. Oil light is off now, but traction control light is now on and engine loses power? Haven't tested oil pressure yet
Was this
answer
helpful?
Yes
No
Thursday, January 6th, 2011 AT 11:09 PM
Tiny
MHPAUTOS
  • EXPERT
What fault codes are you getting with a scan?

Mark (mhpautos)
Was this
answer
helpful?
Yes
No
Friday, January 7th, 2011 AT 1:17 AM
Tiny
WEAVERDAD
  • MEMBER
Ok it throwed a code for knocking and misfires. But can punch the traction control button inside car and it runs like a top. It's like it resets itself everytime you turn it off and you have to push it again. Idk crossing fingers that it keeps working!
Was this
answer
helpful?
Yes
No
Saturday, January 8th, 2011 AT 12:02 AM
Tiny
MHPAUTOS
  • EXPERT
Let me know the exact codes if you can.

Mark (mhpautos)
Was this
answer
helpful?
Yes
No
Saturday, January 8th, 2011 AT 12:06 AM
Tiny
WEAVERDAD
  • MEMBER
Throwing no codes now. Still has a tapping in upper engine just not as bad. Tapping speeds up with engine. It runs and when it drives for a bit traction control light comes on and engine bogs down. You can turn traction control off and it runs fine.
Was this
answer
helpful?
Yes
No
Saturday, January 8th, 2011 AT 8:30 PM

Please login or register to post a reply.

Recommended Guides