Service engine light on

Tiny
ANGELATHOMAS
  • MEMBER
  • 2002 SATURN VUE
  • 6 CYL
  • AWD
  • AUTOMATIC
  • 94,000 MILES
This question is for saturntech9 my service engine soon light is on, and the salesman told me that the sensor needed to be replaced and it would take it off. Well when I start it up and take off in it, the light flashes on and off about 6 times then it starts spudering like im running out of gas then it quites and its fine, its done that twice when I drove it then my signals has stopped working so my question is could this be a sensor causing this?
Do you
have the same problem?
Yes
No
Monday, February 14th, 2011 AT 10:48 PM

19 Replies

Tiny
SATURNTECH9
  • EXPERT
The first thing I need from you is what code's you have in your computer the exact code number's?Also your turn signals are inop?So does the indicator on the dash light light up?Does the light's on the outside front and rear come on with the switch on?The more details the better.
Was this
answer
helpful?
Yes
No
Tuesday, February 15th, 2011 AT 1:03 AM
Tiny
ANGELATHOMAS
  • MEMBER
How do I found out the codes? The dash light comes on, and are you talking about the headlights tail lights? If so they do come on with the switch.
Was this
answer
helpful?
Yes
No
Tuesday, February 15th, 2011 AT 3:54 AM
Tiny
SATURNTECH9
  • EXPERT
You need to go to a auto parts store and have them scan your computer for code's and let me know what the exact code number's are. You said your signal's are inop?Do you mean your turn signal's are inop?If so I need as much info about the turn signal problem as possible.
Was this
answer
helpful?
Yes
No
Tuesday, February 15th, 2011 AT 6:06 PM
Tiny
ANGELATHOMAS
  • MEMBER
The turn signals just stopped working yesterday you could turn them left and right and they did not flash on the dash nor did they flash on the outside of the car, but today they stared working again.
Was this
answer
helpful?
Yes
No
Tuesday, February 15th, 2011 AT 6:23 PM
Tiny
SATURNTECH9
  • EXPERT
So the indicators on the dash lit up and the outside turn signal bulbs lit up they just didn't flash?
Was this
answer
helpful?
Yes
No
Tuesday, February 15th, 2011 AT 6:29 PM
Tiny
ANGELATHOMAS
  • MEMBER
The dash lit up, no the turn signals didnt do anything I would turn them on but it didnt light up or flash. Then after few hours they started working again.
Was this
answer
helpful?
Yes
No
Tuesday, February 15th, 2011 AT 7:38 PM
Tiny
SATURNTECH9
  • EXPERT
So the indicator for the left and right turn signal lit up on the cluster but the front and the back bulbs outside didn't light up?If so you will have to check it with a multimeter when it act's up I suspect a bad flasher relay. Do you have a multimeter?
Was this
answer
helpful?
Yes
No
Tuesday, February 15th, 2011 AT 7:53 PM
Tiny
ANGELATHOMAS
  • MEMBER
No
Was this
answer
helpful?
Yes
No
Tuesday, February 15th, 2011 AT 8:12 PM
Tiny
SATURNTECH9
  • EXPERT
Do you know how to use one and take thing's apart?If not your going to have to find someone to help you with the turn signal's when they act up.
Was this
answer
helpful?
Yes
No
Tuesday, February 15th, 2011 AT 8:35 PM
Tiny
ANGELATHOMAS
  • MEMBER
Went to auto shop and he said that 8 things showed up but one of them showed up several different times. Bank sensor 1, O2 sensor 1 I think this was the one that showed up alot, cylinder #2 misfire, and cylinder #4 misfire. He said that if I got the plugs and wires replaced and the sensor then that should fix. What do you think?
Was this
answer
helpful?
Yes
No
Wednesday, February 16th, 2011 AT 3:14 AM
Tiny
SATURNTECH9
  • EXPERT
It would really help to know all the exact code's number's not what they said and to even know the code number's that only set one time. That way I can get a better idea of what's going on. SO please get and post all the exact code number's you have in your computer.
Was this
answer
helpful?
Yes
No
Wednesday, February 16th, 2011 AT 4:59 AM
Tiny
ANGELATHOMAS
  • MEMBER
PO304 PO150 PO155 PO154 PO300 PO302 PO306
Was this
answer
helpful?
Yes
No
Sunday, February 20th, 2011 AT 12:43 PM
Tiny
SATURNTECH9
  • EXPERT
From the code's you posted I would like to know what step's he used to figure out that you had two bad o2 sensor's bad plug's and the spark plug boot's/wire's?Step by step thing's he did to figure this out. Because I would take care of the o2 sensor code's first then address the miss fire if it was still there. Unless you give that info I can't tell you if he is just guessing or not as to what is wrong with your vue.
Was this
answer
helpful?
Yes
No
Sunday, February 20th, 2011 AT 8:42 PM
Tiny
ANGELATHOMAS
  • MEMBER
He hooked the reading instrument to the computer and the codes came up on it.
Was this
answer
helpful?
Yes
No
Sunday, February 20th, 2011 AT 9:31 PM
Tiny
SATURNTECH9
  • EXPERT
If that's all he did then he did not diagnose it correctly there are trouble tree's that for the o2 sensor code's that lead you to bad sensor's bad wire's connection issue's and possible a bad computer. There is no way he could know for sure by just reading the code number's unless he is some kind of physic.
Was this
answer
helpful?
Yes
No
Sunday, February 20th, 2011 AT 9:41 PM
Tiny
ANGELATHOMAS
  • MEMBER
I took my vue back to the salesman he had me send it to a certain garage and the mechanic called said he had to order a gasket because mine was bad. Could a bad gasket cause the problems I am having?
Was this
answer
helpful?
Yes
No
Thursday, February 24th, 2011 AT 9:58 PM
Tiny
SATURNTECH9
  • EXPERT
So let me ask you this are they paying for this repair under warranty?I asked because you mentioned a sales man sent you to a certain shop. Which gasket are they saying is bad?Let me know so I can answer your question better.
Was this
answer
helpful?
Yes
No
Thursday, February 24th, 2011 AT 10:34 PM
Tiny
ANGELATHOMAS
  • MEMBER
Yes the man that sold me the car paid for it the garage he sent me to I have been there before with a different vehicle. He said they changed the o2 sensor, and the plugs but they had to order a new gasket where they changed the plugs. After I picked my car up it had stopped the spudering and the check engine light had went off, so I hope thats all it was. The only thing I noticed was the mileage dont light up, I can still see how many miles are on the car but it just dont light up I figured it could be a bulb or fuse blown, but I didnt really worry about it since I can still see how many miles there are.
Was this
answer
helpful?
Yes
No
Tuesday, March 1st, 2011 AT 4:55 AM
Tiny
SATURNTECH9
  • EXPERT
The odometer has a bulb to light it up the bulb needs to be replaced. It's a pretty easy repair all you have to do is remove the cluster and replace the bulb for the back side of it.
Was this
answer
helpful?
Yes
No
Tuesday, March 1st, 2011 AT 7:25 AM

Please login or register to post a reply.

Recommended Guides