Front windshield wipers will not work

Tiny
JEEPGUY4LIFE
  • MEMBER
  • 2002 JEEP GRAND CHEROKEE
  • 4.7L
  • V6
  • 4WD
  • AUTOMATIC
  • 195,000 MILES
Font windshield wipers will not turn on when activated with switch. However, when I activate the switch (does not matter what speed), and wiggle the blades a bit, the wipers begin to work. After the vehicle is turned off for a while, I have to wiggle the blades again. Wiper fluid works, relays are good, and fuse is good (obviously). I believe that the motor is going bad. But prior to buying new motor and switching it out, I wanted to describe the exact issue to see if there was another issue causing the problem. Thanks in advance for your replies.
Do you
have the same problem?
Yes
No
Wednesday, June 28th, 2017 AT 9:49 AM

1 Reply

Tiny
CARADIODOC
  • EXPERT
Tugging on the wiper arms is what I would have suggested, and since that made the wipers work, that proved the motor is okay. If you look at the plate the motor is mounted on, you will see there is a brass strip riveted to it, and the other end is under the head of one of the three mounting bolts. That is the ground strap. It is needed because the plate is mounted on rubber isolator bushings to reduce vibration being felt inside the vehicle. It has arced away under the bolt head.

Find a bolt on the motor's gear housing or find or drill a hole in the plate where you can run in a self-tapping screw. Attach a ground wire to that bolt or screw, then attach the other end to a paint-free point on the body. Fixed!
Was this
answer
helpful?
Yes
No
+1
Wednesday, June 28th, 2017 AT 7:41 PM

Please login or register to post a reply.

Recommended Guides