2002 Civic ex stalls when first going into closed loop then runs fine when completely warmed up

Tiny
DKEYSS
  • 2002 HONDA CIVIC
  • 109,000 MILES

Starts fine as engine warms up throttle drops doesn't die but throttle is real sluggish for a few minutes when engine goes to operating temp runs okay

Do you
have the same problem?
Yes
No
Sunday, March 25th, 2012 AT 10:21 PM

6 Replies

Tiny
RASMATAZ
  • MEMBER

Check the idle air control and throttle position sensor-to inclue the fuel pressure-

Was this
answer
helpful?
Yes
No
Sunday, March 25th, 2012 AT 10:25 PM
Tiny
RASMATAZ
  • MEMBER

BTW, do you have a check engine light and when was last tune-up

Was this
answer
helpful?
Yes
No
Sunday, March 25th, 2012 AT 10:27 PM
Tiny
DKEYSS
  • MEMBER

No check engine light plugs and air filter just changed and idle air valve cleaned

Was this
answer
helpful?
Yes
No
Monday, March 26th, 2012 AT 12:31 AM
Tiny
RASMATAZ
  • MEMBER

Check the fuel pressure if its within specs

Was this
answer
helpful?
Yes
No
Monday, March 26th, 2012 AT 2:58 AM
Tiny
SONSKIETOT16
  • MEMBER

Hi rasmataz I do have a same problem on my 94 civic. It has a check engine light. Whats wrong on it?

Was this
answer
helpful?
Yes
No
Monday, April 23rd, 2012 AT 4:26 AM
Tiny
RASMATAZ
  • MEMBER

To: sonskietot16

You need to have the computer scanned for code/s this is your starting point of diagnosis

Was this
answer
helpful?
Yes
No
Monday, April 23rd, 2012 AT 8:17 AM

Please login or register to post a reply.

Other Engine Stall Questions