The instrument panel (RPM, speedo, odometer.

Tiny
ANONYMOUS
  • MEMBER
  • 2002 CHRYSLER CONCORDE
  • 1 MILES
The instrument panel (rpm, speedo, odometer, gas gauge) and the taillights don't work. We pulled the fuse #7 for those items and cleaned the terminal and replaced it with a new 20 amp fuse. Still the same problem.
Sunday, February 3rd, 2013 AT 9:42 PM

13 Replies

Tiny
ASEMASTER6371
  • EXPERT
The cluster may have failed. Remove the cluster and clean the connections behind it.

Roy
Was this
answer
helpful?
Yes
No
Sunday, February 3rd, 2013 AT 9:44 PM
Tiny
DEEDEE2009
  • MEMBER
What about both taillights not working?
Was this
answer
helpful?
Yes
No
Sunday, February 3rd, 2013 AT 9:51 PM
Tiny
ASEMASTER6371
  • EXPERT
Ok, that may be a different issue. There is a fuse for the tail lights, check that

check the sockets for power with a test light. Does the license light work?

Otherwise look at grounds and the wiring in the trunk

Roy
Was this
answer
helpful?
Yes
No
Sunday, February 3rd, 2013 AT 10:19 PM
Tiny
DEEDEE2009
  • MEMBER
The fuse for the tail lights is also the fuse for the instrument cluster. I did check the socket that the fuse plugs in to and there is no power going to the fuse. The license light does not work. So, if there is no power going to the fuse how do I remedy that problem? Is this an easy fix?
Was this
answer
helpful?
Yes
No
Monday, February 4th, 2013 AT 1:23 AM
Tiny
ASEMASTER6371
  • EXPERT
Diagram below that has a park lamp relay. Check this for power when the headlight switch is on

Roy
Was this
answer
helpful?
Yes
No
Monday, February 4th, 2013 AT 1:31 AM
Tiny
DEEDEE2009
  • MEMBER
This diagram does not compare to the fuse/relay box under my hood. I have taken a picture of it. If you could send me your email address I can send you a picture of what mine looks like.
Thanks,
Deanna
Was this
answer
helpful?
Yes
No
+1
Monday, February 4th, 2013 AT 6:01 PM
Tiny
DEEDEE2009
  • MEMBER
Tell me how I can donate more money to get this question answered to my satisfaction. The fuse/relay diagram you showed me is not the same setup as I have under the hood. Can I send you a pic somehow of what my setup looks like?
Was this
answer
helpful?
Yes
No
Monday, February 4th, 2013 AT 8:39 PM
Tiny
ASEMASTER6371
  • EXPERT
Sorry, at work with no acess today.
Was this
answer
helpful?
Yes
No
Monday, February 4th, 2013 AT 11:26 PM
Tiny
ASEMASTER6371
  • EXPERT
Roybelding@gmail. Com
Was this
answer
helpful?
Yes
No
Monday, February 4th, 2013 AT 11:27 PM
Tiny
DEEDEE2009
  • MEMBER
Hello?
Was this
answer
helpful?
Yes
No
Wednesday, February 6th, 2013 AT 7:55 PM
Tiny
DEEDEE2009
  • MEMBER
Did you get my picture of the fuse box under the hood of 2002 Chrysler Concorde? I would be happy to pay you money to continue trying to fix my problem. I just need some expert help here, I don't know what to do. And I don't know how to send you more money.
Was this
answer
helpful?
Yes
No
Thursday, February 7th, 2013 AT 7:47 PM
Tiny
CHUCK MCCOY2
  • MEMBER
OK I had the same problem with the instrument panel. All fuse was good so I disconnected the battery and let it sit for 30 mins and hooked it back up and everything works. I would try this 1st cheap and easy.
Was this
answer
helpful?
Yes
No
Wednesday, July 19th, 2017 AT 11:27 AM
Tiny
KEN
  • ADMIN
Great addition to this thread! Please feel free to help out whenever you are on the site :)

Cheers, Ken
Was this
answer
helpful?
Yes
No
Thursday, July 20th, 2017 AT 10:19 AM

Please login or register to post a reply.

Recommended Guides