2002 Chevrolet Silverado Died on the road

Tiny
FI50405
  • MEMBER
  • 2002 CHEVROLET SILVERADO
  • 190,000 MILES
Checked fuel pump have 60 psi, checked For Spark. Had spark Replaced crank sencer still won't start. I also found a ground wire broken off At the front frame and can not find where it comes from it is just long enough to reach the engine by crank pulley.
Do you
have the same problem?
Yes
No
Tuesday, August 6th, 2013 AT 2:26 PM

9 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Okay, you have fuel pump pressure and spark. Is the spark a hot blue snapping spark? Also, have you checked to see if there is power to the fuel injectors?

Try this. See if the engine will start with starting fluid. If it does, then fuel is the issue here. Let me know what you find. Something tells me the injectors are not getting power.
Was this
answer
helpful?
Yes
No
Tuesday, August 6th, 2013 AT 7:11 PM
Tiny
FI50405
  • MEMBER
I tried starting fluid. Did not start. I put a code reader on the truck. Codes all passed. I checked injecter fuses had power. I checked spark at the No. 1 Had Spark. I checked Spark at coil OK. I checked spark in side Dist. Cap. I had spark
I did replace Cap And Rotar I pulled fuel relay Tried to start thinking maybe flooded also tried starting fluid sometimes sounds like its trying but does not
Was this
answer
helpful?
Yes
No
Wednesday, August 7th, 2013 AT 12:03 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Is the spark to the plugs a hot blue snapping spark or is it orange or white? Also, if you pull a plug out after trying to start it, is the plug wet?

Since it won't start with starting fluid, it sounds like it is ignition related. However, you are telling me you have spark. Let me know if the spark is strong. If it is, then it should have started with starting fluid. Also, tell me where you sprayed the starting fluid. Was it in the air box or did you spray it directly into the throttle body?
Was this
answer
helpful?
Yes
No
Wednesday, August 7th, 2013 AT 2:51 PM
Tiny
FI50405
  • MEMBER
I put Starting Fluid right in The Throttle body. I did not pull plug after I Tried to start.
I had a spark tester and the spark jumped the tester I will check collor again could have been white or orangewhite
Was this
answer
helpful?
Yes
No
Wednesday, August 7th, 2013 AT 4:11 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
If it won't start with starting fluid, then it has to deal with spark. Let me know what you find.
Was this
answer
helpful?
Yes
No
Wednesday, August 7th, 2013 AT 9:42 PM
Tiny
FI50405
  • MEMBER
I put New Coil Wire on the started right up. Thanks for the Help
Was this
answer
helpful?
Yes
No
Thursday, August 8th, 2013 AT 1:18 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Were you getting spark to the engine prior to the new coil wire? I bet it was too weak to run the engine. Well, I'm glad you got it going. Let me know if you have other questions.

Joe
Was this
answer
helpful?
Yes
No
Thursday, August 8th, 2013 AT 6:12 PM
Tiny
FI50405
  • MEMBER
I was getting spark at the coil at the carbin tip in side the dist. Cap and I thought it was a good sparck but it started instantly when I put a made up coil wire just to try it.
Thanks again for the information.
Was this
answer
helpful?
Yes
No
Friday, August 9th, 2013 AT 7:03 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Ya, it must not have been making it to the plugs. Thanks for your question. Take care.

Joe
Was this
answer
helpful?
Yes
No
Friday, August 9th, 2013 AT 1:44 PM

Please login or register to post a reply.

Recommended Guides