2001 Mercury Mountaineer Radio

Tiny
KPATRICK1
  • MEMBER
  • 2001 MERCURY MOUNTAINEER
  • AUTOMATIC
Hello. I have a 2001 Mercury Mountaineer. My question is concerning the radio. When I'm in my truck the radio plays fine. The one problem is the light on the radio doesn't show. I can't see the station its on nor can I see the time. Please help!
Do you
have the same problem?
Yes
No
Tuesday, July 7th, 2015 AT 4:43 PM

1 Reply

Tiny
RANDY B
  • EXPERT
There is no light bulb. The display is a vacuum florescent display, meaning a vacuum tube. This is a REAL frustrating problem to repair on Ford radios. On Chrysler models there are one or three places to look for intermittent solder connections, depending on the model. On Fords, there's over 80 places that can cause this. I tell dealers it will be at least two weeks before they get the radio back if they want the same one, otherwise I just send one that I repaired previously. It never fails, ... Once I think it's repaired, I let it play on the test bench, and after about a week, it acts up again and I have to start all over.

The way this is repaired through the dealer is three circuit boards will be replaced with what are supposed to be "updated" versions, but those will also develop the same problems eventually. I have those boards but they cost over $200.00 for the set so I don't give up until I have the original ones repaired.
Was this
answer
helpful?
Yes
No
+1
Tuesday, July 7th, 2015 AT 8:06 PM

Please login or register to post a reply.

Sponsored links