Wont pull in drive

Tiny
DAVID6107195
  • MEMBER
  • 2001 KIA SEPHIA
  • 110,000 MILES
My 2001 KIA Sophia wont pull in drive reverse or any gear at all I have check the fluid and tried to reset the computer and all so took line off going to radiator and no fluid will com out does this mean pump is out or electrical problem

it was working fine backed out of driveway and put it in drive and pulled up to mailbox and put it in park got the mail and put it in drive and it would not move put it in reverse and still would not move what could it be
Do you
have the same problem?
Yes
No
Monday, February 20th, 2012 AT 6:31 AM

4 Replies

Tiny
RASMATAZ
  • MECHANIC
  • 75,990 POSTS
Check the driveaxles might not be engaging with the transmssion, also check gear linkage if okay -have the transmission further checked-the symptoms indicates transmission slippage-get it pressure tested-
Was this
answer
helpful?
Yes
No
Monday, February 20th, 2012 AT 6:43 AM
Tiny
DAVID6107195
  • MEMBER
  • 3 POSTS
I have checked the drive axles they r fine and the linkage cable is working right
Was this
answer
helpful?
Yes
No
Monday, February 20th, 2012 AT 6:48 AM
Tiny
DAVID6107195
  • MEMBER
  • 3 POSTS
What else could it be the pump or something electrical
Was this
answer
helpful?
Yes
No
Monday, February 20th, 2012 AT 6:52 AM
Tiny
RASMATAZ
  • MECHANIC
  • 75,990 POSTS
Take it to a tranny shop you have an internal problem-you can try checking the TPS and VSS sensors-
Was this
answer
helpful?
Yes
No
Monday, February 20th, 2012 AT 7:03 AM

Please login or register to post a reply.

Sponsored links