2001 Infiniti QX A/C

Tiny
KTOOM300
  • MEMBER
  • 2001 INFINITI QX
  • 130,000 MILES
Have to drive several miles before blowing cold air. Clutch is engaged. Low pressure line is hot until it starts cooling. Line instantly turns cold. All pressures look good. Had it checked
at a shop and was told it was compressor but I don't think so because it works so well. Also after it starts to cool it will work the rest of the day. I understand what this is a variable displacement compressor and have used a lot of had pumps like this and they are good or bad most of the time. I think it is the valve on the evaporator coil, but don't want to take it out with out knowing more.



Do you
have the same problem?
Yes
No
Wednesday, September 11th, 2013 AT 6:36 PM

8 Replies

Tiny
SATURNTECH9
  • EXPERT
If I could get those high and low pressures at idle that would really help. From what I know if the pressures were good it should be blowing cold.I would like the pressures high and low At idle and at About 2,000 ROMs?
Was this
answer
helpful?
Yes
No
Wednesday, September 11th, 2013 AT 8:18 PM
Tiny
KTOOM300
  • MEMBER
I will have to take it back to the shop, I do not have gauges.
Was this
answer
helpful?
Yes
No
Thursday, September 12th, 2013 AT 12:26 PM
Tiny
SATURNTECH9
  • EXPERT
With ac without seeing the pressures its hard to do a diagnosis. They checked to make sure it has the proper charge amount correct?
Was this
answer
helpful?
Yes
No
Thursday, September 12th, 2013 AT 12:59 PM
Tiny
SATURNTECH9
  • EXPERT
Also if you could ask him what about the pressures makes him think its a bad compressor? Because you said the pressures were good but if that were the case then why wasn't it blowing cold and why did he say bad compressor.
Was this
answer
helpful?
Yes
No
Thursday, September 12th, 2013 AT 1:05 PM
Tiny
KTOOM300
  • MEMBER
He thinks the variable part of the compressor is sticking. I will go back tomorrow.
He used "Mitchell" to trouble shoot. I do not understand how it turns cold like someone
Flipped a switch. Once it gets cold it works great and the auto temp control works as well.
Looking at the factory service manual there is a mixing or temp control valve on the end
of the evaporator coil, I could see this sticking.
Was this
answer
helpful?
Yes
No
Friday, September 13th, 2013 AT 6:36 PM
Tiny
SATURNTECH9
  • EXPERT
I have seen expansion valves stick also vanes in the compressor stick and the compressor Come apart inside and cool sometimes and sometimes not cool.
Was this
answer
helpful?
Yes
No
Friday, September 13th, 2013 AT 6:50 PM
Tiny
KTOOM300
  • MEMBER
Well shop is closed so I got my old gauges out and bought some adaptors.

The psi may not be just right but you can see what happens. At idle not working,

low 40
high 100

when it gets cool

30 and 240
Was this
answer
helpful?
Yes
No
Saturday, September 14th, 2013 AT 1:22 PM
Tiny
SATURNTECH9
  • EXPERT
The low side being 40 isn't bad but the high is 100psi is way low. So the pressures aren't always good let me do some looking In my repair manual.
Was this
answer
helpful?
Yes
No
Saturday, September 14th, 2013 AT 3:44 PM

Please login or register to post a reply.

Recommended Guides