It crank but won't start. (No power to crank position sensor)

Tiny
JGEMNO
  • 2001 FORD EXPEDITION
  • 81,000 MILES

Check fuel pump, selinoid, all fuses, battery, starter.

Do you
have the same problem?
Yes
No
Monday, December 12th, 2011 AT 12:34 AM

5 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,362 POSTS

Which sensor are you referring to? Also, is there spark and fuel to the engine?

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Monday, December 12th, 2011 AT 12:35 AM
Tiny
JGEMNO
  • MEMBER

Crankshaft position sensor, there's spark and fuel to engine, if I jumped it, works fine

Was this
answer
helpful?
Yes
No
Monday, December 12th, 2011 AT 12:51 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,362 POSTS

Okay, if you have spark and fuel to the engine, it should run. Are you sure the fuel pressure is within the manufacturer's specs and the spark is a good hot blue snapping spark? Also, make sure the fuel injectors are getting power.

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Monday, December 12th, 2011 AT 12:54 AM
Tiny
JGEMNO
  • MEMBER

Fuel pressure don't know, fuel injectors are power yes.

Was this
answer
helpful?
Yes
No
Monday, December 12th, 2011 AT 1:22 AM
Tiny
JACOBANDNICKOLAS
  • EXPERT
  • 68,362 POSTS

If there is no power to the crank sensor, check the wiring between it and the PCM. Check the plug on PCM for corrosion or damage.

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Monday, December 12th, 2011 AT 1:31 AM

Please login or register to post a reply.

Related Crankshaft Crankshaft Position Sensor CKS Questions

Help us by donating