Chevy Cavalier - AC/Heat not staying on

Tiny
ANICHOLS
  • MEMBER
  • 2001 CHEVROLET CAVALIER
  • 4 CYL
  • AUTOMATIC
  • 160,000 MILES
I have a 2001 Cavalier. The AC/Heat/Defrost will turn on but only run for approx 2 minutes then it kicks itself off. We have replaced the blower motor, 2 fuses, added freon, replaced thermostat, replaced the temp control panel (not sure the technical name for this). It is still not staying on. Can anyone please help with this? Thanks
Do you
have the same problem?
Yes
No
Tuesday, May 31st, 2011 AT 1:44 PM

8 Replies

Tiny
WRENCHTECH
  • EXPERT
What exactly is shutting off, blower, compressor, air flow direction?
Was this
answer
helpful?
Yes
No
Tuesday, May 31st, 2011 AT 2:53 PM
Tiny
ANICHOLS
  • MEMBER
I am not a car person. My husband is at work and I can't reach him to ask specifics. However if you put your hand up to the vents you can feel cold air behind it but it doesn't blow in. Does this help at all? If not I will have him repost the correct answer once he gets home.
Was this
answer
helpful?
Yes
No
Tuesday, May 31st, 2011 AT 3:17 PM
Tiny
WRENCHTECH
  • EXPERT
I'm afraid if you're finding it that difficult to explain the symptoms it's going to be impossible for me to instruct you on any test procedures.
Was this
answer
helpful?
Yes
No
Tuesday, May 31st, 2011 AT 3:20 PM
Tiny
CARRIE BOUCHEE
  • MEMBER
I have a 2000 Cavalier that we are having the same problem with. The blower would blow on occasion and then stop so we assumed it was low on freon and have since recharged the ac system. The blower still is not blowing. There is a button on the dash for the AC when it is pushed in it shows a green light, when I roll the dial to defrost this light comes on? Is this light suppose to come in when AC is off while on defrost? We do not know what else could be causing the blowers to not blow. Can you help us?
Was this
answer
helpful?
Yes
No
+1
Wednesday, June 1st, 2011 AT 12:29 PM
Tiny
WRENCHTECH
  • EXPERT
Please start a separate question of your own.
Was this
answer
helpful?
Yes
No
Wednesday, June 1st, 2011 AT 12:31 PM
Tiny
CARRIE BOUCHEE
  • MEMBER
Sorry it is the blower that does not come on at all. When it first started to go it would blow when you first started the car then just shut down. Now it will not go on at all. Some have said it could be the blower moter or the switch. Not sure. What are your thoughts?
Was this
answer
helpful?
Yes
No
Thursday, June 2nd, 2011 AT 12:20 PM
Tiny
WRENCHTECH
  • EXPERT
Again. Start a new question of your own please.
Was this
answer
helpful?
Yes
No
Thursday, June 2nd, 2011 AT 12:35 PM
Tiny
ANICHOLS
  • MEMBER
I figured out the problem. The first fuse that we replaced ended up being bad. So after I spent about $250 on other parts that ended up not being needed it was another $9 fuse and it works great!
@Carrie.I do know on my car in the manual it states that the green light will come on when defrost is on regardless of the A/C. I'm not a car person but with the experience I had I would definately replace the cheap fuses under the hood first. Good Luck!
Was this
answer
helpful?
Yes
No
Thursday, June 2nd, 2011 AT 1:42 PM

Please login or register to post a reply.

Recommended Guides