CLIMATE CONTROLS

Tiny
MOMO8210
  • MEMBER
  • 2001 CADILLAC SLS
  • V8
  • 2WD
  • AUTOMATIC
  • 119 MILES
Why doesn't my driverside vent controls work? A/c only blows cold on the pass side no matter which vents are selected (floor, cabin, or defog). Also, same problem with heater on. I think maybe vent control module is bad? Where is it and how do I get to it to check? Problem first occured after supposedly certified techs were troubleshooting low coolant a/c and estimating repair cost. Your time is much appreciated!
Do you
have the same problem?
Yes
No
Thursday, June 16th, 2011 AT 9:22 PM

5 Replies

Tiny
FACTORYJACK
  • EXPERT
Not rear clear on the exact concern, so I will ask you a few questions. The drivers side zone, does it change modes, or not, and does the temperature stay hot/warm/cold? The passenger side zone always blows cold, but changes modes as commanded? The climate module(IPM) is also the control panel, and there is no real way for you to 'check it'. What I would direct you to do at this point, is perform a diagnostic system check, by pressing info up, and on/off, with the key 'on'. Hold til all of the segments illuminate, the info center will read 'ALL?'. Have a pen and paper, press on/off and the display will change to 'ALL CODES?', Press on/off again, and be prepared to read/record codes. They will display alphabetically by module. What possibly is happening, is default operations in response to faults, and if so, there should be codes. Look specifically for IPM codes, but record and post all codes if possible. With the feature you have enabled, you can read and clear codes by commands, and if you shut the key off, or miss a code or two, don't worry, you can go through it as many times as necessary.
Was this
answer
helpful?
Yes
No
Thursday, June 16th, 2011 AT 9:45 PM
Tiny
MOMO8210
  • MEMBER
Thanks for the quick reply. The drivers side changes modes and is in sync with the pass side. The air temp comming from the drivers side vents is warm (perhaps ambient temp. Its pretty warm here in Tn.)And the temp appears to be constant. The a/c air coming from the pass vents seem to be constant also. I'll go see if I can pull the codes now and get right back. Thanks a lot.
Was this
answer
helpful?
Yes
No
Thursday, June 16th, 2011 AT 10:52 PM
Tiny
MOMO8210
  • MEMBER
There were no IPM codes but there were some ddm, irc, ttm history codes that I accidentally cleared before I got them recorded. I intended to restart the car and turn on the a/c and then check for the codes again but guess what. Clearing the codes apparently fixed the problem. Nice! Thanks again for your help!
Was this
answer
helpful?
Yes
No
Thursday, June 16th, 2011 AT 11:15 PM
Tiny
FACTORYJACK
  • EXPERT
If the fault returns, it could be possibly a faulty blend actuator, especially if it is a side to side difference. What happens is if an actuator is determined to be overtraveled(outside of predetermined high/low limits), it will default to a position, usually full hot or full cold. In reading the description and operation of the system, the DDM(drivers door module) does have an effect, but it seems to be whether driver 1 or driver 2 personalization settings are being requested.
Was this
answer
helpful?
Yes
No
Friday, June 17th, 2011 AT 1:51 AM
Tiny
MOMO8210
  • MEMBER
Again, thanks for the feedback and info. I'll have a good logical starting position should the problem reoccur. My thoughts are that something happened during the original troubleshooting process started by the techs to begin with.I'll keep my fingers crossed. SA.
Was this
answer
helpful?
Yes
No
Friday, June 17th, 2011 AT 3:47 AM

Please login or register to post a reply.

Recommended Guides