HOW DO I REPAIR MY CRUISE CONTROL.? 10 - 15 SECOND DELAY BEFORE ACTIVATING

2000 Nissan Frontier

Tiny

Bill Jensen

November, 16, 2011 AT 12:59 AM

When I engage my C/C button. Button lights up green and the word "Cruise" lights up green next to the odometer. (So far so good) Now when I hit "Set" (Say at 60 mph), The vehicle speed slows and just Coasts until it reaches 50 mph. Then it engages and slowly speeds up until it reaches the "Set" speed of 60 mph. What's causing this delay?
V6, Manual, 4X4, Ext Cab.

Thanks for your help.

FOUND 160 RELATED QUESTIONS

5 Answers

Tiny

ProAutoTech

November, 16, 2011 AT 1:42 AM

I'm not sure at all yet, but I need to ask- stock tire size? And any other gremlins with the speedometer that are noticable like delayed speedo response/

Tiny

Bill Jensen

November, 16, 2011 AT 2:06 AM

Yes. Stock wheels and Tires. Speedometer and RPM gauge works perdfectly. Also. Sometimes when going up a hill the c/c Never does engage. But on level roadway it always engages. Although not for 10 - 15 seconds. Hit "set" button at 60 mph. Then truck coasts loses speed to 50 mph then begins a slow climb back up and stays correctly engaged at 60. Often this whole process can take up to 20 seconds.

Bill

Tiny

mhpautos

November, 17, 2011 AT 9:36 AM

This is a factory cruise control we are looking at?

Tiny

Bill Jensen

November, 20, 2011 AT 7:14 PM

Yes. This is the original C/C. Checked fuses. Cable from Servo to throttle linkage looks fine. I was told it could be a Vacuum leak. How would I check that?

Thanks!

Tiny

Bill Jensen

December, 1, 2011 AT 10:32 PM

Is this now a Dead question?

Please login or register to post a reply.

Cabin Air Filter Replacement
Window Regulator and Motor Replacement Honda