THE OIL PRESSURE GAUGE IN MY 2000 JEEP GRAND ...

  • Tiny
  • Jeepy13
  • 2000 JEEP GRAND CHEROKEE
  • 188 MILES

The oil pressure gauge in my 2000 Jeep Grand Cherokee v8 4.7L fluctuates as I use the accelerator. It sits around 0psi anytime I am under 30mph and only goes as high as 40-50psi when on the highway. The "check gauges" light always comes on but since fluctuates like a speedometer would when you change speeds, it goes off all the time. Please help!

Do you
have the same problem?
Yes
No
Friday, December 28th, 2012 AT 1:25 AM

7 Replies

  • Tiny
  • Rasmataz
  • MEMBER

Check the actual oil pressure with a mechanical gauge if its within specs- if it is consider replacing the oil pressure sending unit make sure its cleaned and properly connected before you replace it doing this and problem remain the same-Try an engine flush, the oil pump pressure relief valve could be sticking-

Was this
answer
helpful?
Yes
No
Friday, December 28th, 2012 AT 1:34 AM
  • Tiny
  • Jeepy13
  • MEMBER

Great! Thank you so much for the guidance! Much appreciated!

Was this
answer
helpful?
Yes
No
Friday, December 28th, 2012 AT 3:01 AM
  • Tiny
  • Rasmataz
  • MEMBER

You're welcomed and Happy New Year

Was this
answer
helpful?
Yes
No
Friday, December 28th, 2012 AT 4:17 AM
  • Tiny
  • ShadeTreeJack
  • MEMBER

I was asked to look at a Durango, 4.7L. The oil pressure gauge occasionaly drops to zero. The lifters get loud, so I trust this is not just a oil pressure sending unit issue. I see the oil pump is on the crank, not in the bottom pan, So I will replace it. Is the pressure regulator part of the pump assembly? It looks like it from the parts store pictures . I also have read where the pickup screen gets sludged up; will a engine oil flush clean this? Do you recommend a brand?

Thank you in advance.

Was this
answer
helpful?
Yes
No
Thursday, February 14th, 2013 AT 1:51 AM
  • Tiny
  • ShadeTreeJack
  • MEMBER

I also meant to ask jeepy13 - was your issue the pump or the sending unit?

Was this
answer
helpful?
Yes
No
Thursday, February 14th, 2013 AT 1:52 AM
  • Tiny
  • Jeepy13
  • MEMBER

It was my sending unit. Since I've had it replaced there's been no problems!

Was this
answer
helpful?
Yes
No
Thursday, February 14th, 2013 AT 2:17 AM
  • Tiny
  • Rasmataz
  • MEMBER

Thanks for coming back with the fix-

Was this
answer
helpful?
Yes
No
Thursday, February 14th, 2013 AT 8:14 AM

Please login or register to post a reply.

Other Instrument Cluster Gauge Oil Pressure Replace/Remove Questions