2000 GMC Jimmy

Tiny
CRASHUP81
  • MEMBER
  • 2000 GMC JIMMY
  • 6 CYL
  • 4WD
  • AUTOMATIC
How much fuel pressure should I expect at the schroder valve. Im at 47 key on and 50 running
Do you
have the same problem?
Yes
No
Monday, March 14th, 2011 AT 9:27 PM

9 Replies

Tiny
JDL
  • EXPERT
My info says 60--66Psi, key on engine off. After it is running, it will run at a lower pressure.
Was this
answer
helpful?
Yes
No
Monday, March 14th, 2011 AT 9:35 PM
Tiny
CRASHUP81
  • MEMBER
What can cause my maf (mass air flow) sensor to set off my check engine light?
Was this
answer
helpful?
Yes
No
Monday, March 14th, 2011 AT 9:39 PM
Tiny
JDL
  • EXPERT
What is the actual code number? I'll try to look it up? Tap on the maf sensor, engine running, any idle issue. I'd have to check voltage and ground for the maf sensor.
Was this
answer
helpful?
Yes
No
Monday, March 14th, 2011 AT 10:04 PM
Tiny
CRASHUP81
  • MEMBER
Code that shows up is p0102 (circut low imput) ive replaced the maf sensor with a (used) one. Ive cleaned it carefully with maf cleaner. When I plug the maf and iat sensors in there seems to be a change in rpm. (Lower) while disconnected the jimmy starts and runs better, but by all means not right. Ive changed the fuel filter 3 times. Air filter just as many. Have run 4 cans of seafoam and many other cleaners throughout. Sometimes it starts right up others I have to spray starting fluid into the intake. Dosent seem to matter if im driving down the road or in park in the garage, if I open the throttle wide open it may run like a champ or stall out. No funky smoke out of exhaust or anything. Have also just changed the ect sensor. Maybe a bad wire I dunno. Thanx for helping. Advice is always good :)
Was this
answer
helpful?
Yes
No
Tuesday, March 15th, 2011 AT 2:10 AM
Tiny
JDL
  • EXPERT
Below is wiring for maf, you can check voltage and ground. Could be a problem with may sensor signal to pcm, wiring circuit. You may need to use a scanner that will show live engine data, so you can see what the maf sensor is doing.
Was this
answer
helpful?
Yes
No
Tuesday, March 15th, 2011 AT 6:31 PM
Tiny
CRASHUP81
  • MEMBER
Thank you---- headed out to check on wires.
Was this
answer
helpful?
Yes
No
Tuesday, March 15th, 2011 AT 7:24 PM
Tiny
JDL
  • EXPERT
Let us know.
Was this
answer
helpful?
Yes
No
Tuesday, March 15th, 2011 AT 7:27 PM
Tiny
CRASHUP81
  • MEMBER
Hot damn. Its been a month. Ive replaced the maf. The connector. The iat sensor and connector. The ect sensor and connector. Changed the map sensor. Have checked voltage on all of these plus others. All was well. All fuses are good. Cleaned the body ground wires. Checked double checked triple friggen checked. Seriously waht the f@#k can it be. Oh yea changed the fuel filter twice the pcv valve. Checked and changed the hvac lines if looked cracked or soft. Had fuel pressure tested, again all is well.
Was this
answer
helpful?
Yes
No
Friday, April 15th, 2011 AT 1:10 AM
Tiny
JDL
  • EXPERT
If all is well, that's great.
Was this
answer
helpful?
Yes
No
Monday, April 25th, 2011 AT 2:45 PM

Please login or register to post a reply.

Recommended Guides