I RECENTLY INSTALLED REAR BREAKPAD FOR THE HAND ...

2000 Ford Expedition

Tiny

rholando

November, 25, 2012 AT 7:37 AM

I recently installed rear breakpad for the hand break(foot).
the handbreak light turns on during the light test on the dashboard. But when ever I put the handbreak on the light indicator does not come on. So most of the time I forget that the handbreak si enganged because there is no light indicator. How do you fix it?

8 Answers

Tiny

JDL

November, 25, 2012 AT 3:15 PM

Check the parking brake switch. That switch shows to be ground for the lite on the dash, according to my info.

Tiny

JDL

November, 25, 2012 AT 3:15 PM

Check the parking brake switch. That switch shows to be ground for the lite on the dash, according to my info.

Tiny

JDL

November, 25, 2012 AT 3:16 PM

Sorry about the double post.

Tiny

rholando

November, 25, 2012 AT 3:31 PM

Hi JDL,

Thanks for replying to my message, but I have difficulty figuring where the parking break switch is located, and what to look for regarding the ground? Sorry. : )

Tiny

JDL

November, 25, 2012 AT 5:19 PM

It is on right side of parking brake lever. The switch itself is the ground.

Tiny

JDL

November, 25, 2012 AT 5:20 PM

I belive the switch is grounded through the mounting bolts.

Tiny

rholando

November, 28, 2012 AT 5:48 AM

Hi JDL,

I tried looking for the description you told me I think the site is to tight to see, anyway the light works intermittently sometimes when I push the hand break it would appear in the dashboard and sometimes it wont. Thanks.

Tiny

JDL

November, 28, 2012 AT 4:30 PM

Maybe this will give you better idea.

Please login or register to post a reply.

Replace Your Turn Signal Switch Like a Pro