Replaced 2

Tiny
LABMANLYNNDAIRYCOM
  • 2000 CHRYSLER CONCORDE
  • 100,000 MILES

Replaced 2.7 engine with 3.5 and car ran good for 2 weeks now after I drive 2 miles engine shuts off no spit no sputter and wont restart after 5 minutes car starts right up and runs fine for as long as I have driven it. Next day same thing.I have replaced Crank sensor but no difference

Do you
have the same problem?
Yes
No
Tuesday, October 30th, 2012 AT 6:44 PM

3 Replies

Tiny
CARADIODOC
  • EXPERT
  • 26,781 POSTS

Have you checked for diagnostic fault codes. The camshaft position sensor is a more common failure item. They both often become heat-sensitive and work again once they cool down.

Did you have to replace the Engine Computer or was it running okay with the one from the 2.7L.

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Wednesday, October 31st, 2012 AT 12:11 AM
Tiny
LABMANLYNNDAIRYCOM
  • MEMBER

There are no codes. It's the same computer from the 2.7.
Could the camshaft sensor cause the engine to shut off?

Was this
answer
helpful?
Yes
No
Wednesday, October 31st, 2012 AT 11:16 AM
Tiny
CARADIODOC
  • EXPERT
  • 26,781 POSTS

Absolutely. The Engine Computer wants to know when the engine is rotating, (cranking or running) so it knows when to turn on the automatic shutdown (ASD) relay. It knows that by the pulses it receives from the cam and crank sensors. When it sees those pulses and turns the ASD relay on, that sends current to the ignition coil(s), injectors, fuel pump or pump relay, alternator field, and oxygen sensor heaters.

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Thursday, November 1st, 2012 AT 7:24 AM

Please login or register to post a reply.

Related Engine Stall Questions

Help us by donating