I have a 2000 Cadillac Escalade and iM having a problem, the front lights dim on and off by there self

Tiny
FREDDIE5360
  • MEMBER
  • 2000 CADILLAC ESCALADE
  • 104,692 MILES
I have a 2000 cadillac escalade and im having a problem, the front lights dim on and off by there self when there is no key in the ignition, and the next day i go to start it and the battery and everything is dead and it will not start... it does it randomly when it wants to do it... I notice when they take the head light modulator box out that works my high beams and make the high beam light switch from high to low,and leave only my low beams working without the high beams, i dont seem to have the issue and it doesnt happen...but soon as they replace it back to give me back my high beams back it randomly starts doing it all over again..the lights will dim on and off by there self randomly killing my battery and making my truck not start the next day... and i took it to the dealer ship and they said they can not run tests until it duplicates again...but the issue is it does it when it wants to do it..there is no set time it does it...my mom says she notice that when i drive it for awhile than park it later on that night late it randomly dims on and off.... the yellow part of the fronts lights dim and the bottom of it dim it does it on both sides of the vehicle but the middle part of the lights do not flicker or dim on and off only the side corners and bottom of it does it..but the dealer ship said they can not get it to duplicate i told them it does it randomly at any point it wants..i really need help to figure out how to track this down or find out the is http://www.2carpros.com/questions/newsue..why do my head lights dim on and off by there self without keys in the ignition i dont understand what to look for or search to fix it.

i attached a photo of the lights as they were dimming the part that is lit up is the section that keeps dimming on and off by there self
Do you
have the same problem?
Yes
No
Tuesday, October 18th, 2011 AT 9:08 PM

1 Reply

Tiny
HMAC300
  • EXPERT
Check to see if the grounds are clean and tigh ton the left radiator support adn right front of engine compartment. Also the gorunds on left side of dash. They will all have black wires going to them. Make sure your battery cables are all clean and tight. It's possible it cold be a body or drlmodule causing this though.
Was this
answer
helpful?
Yes
No
Wednesday, October 19th, 2011 AT 12:35 AM

Please login or register to post a reply.

Sponsored links