Bad day

Tiny
ALDOBY87
  • MEMBER
  • 1999 MITSUBISHI GALANT
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 170 MILES
I was driving my car up a bridge and it started loosing power so I pushed the gas and it started making a clicking noise, I got off the road as soon as was off the bridge while I was slowing down car died and can not get it to restart. The starter spins and everything seems to be in order any help would be greatly appreciated.
thank you,
Allyn Doby
Do you
have the same problem?
Yes
No
Tuesday, August 9th, 2011 AT 2:00 PM

5 Replies

Tiny
WRENCHER1
  • MEMBER
Check all your fluid levels
Was this
answer
helpful?
Yes
No
Tuesday, August 9th, 2011 AT 2:27 PM
Tiny
ALDOBY87
  • MEMBER
I checked the fluids the coolant was empty I refilled it but what do I need to proceed with now? The car is still just spinning the starter when I try to turn it over.
Was this
answer
helpful?
Yes
No
Tuesday, August 9th, 2011 AT 2:45 PM
Tiny
WRENCHER1
  • MEMBER
That's what I was afraid of. You need to do a complete compression test now. You may have fried the motor.
Was this
answer
helpful?
Yes
No
Tuesday, August 9th, 2011 AT 2:51 PM
Tiny
ALDOBY87
  • MEMBER
Fried my engine? Like blown head gasket or worse?
Was this
answer
helpful?
Yes
No
Tuesday, August 9th, 2011 AT 3:13 PM
Tiny
WRENCHER1
  • MEMBER
Blown head gasket or possibly worse, yes, depending just how hot it got. If you drove it until it stopped on it's own, it's could be real serious.
Was this
answer
helpful?
Yes
No
Tuesday, August 9th, 2011 AT 3:39 PM

Please login or register to post a reply.

Sponsored links