Turn signals not working

Tiny
CBROWN71
  • MEMBER
  • 1999 MERCURY COUGAR
Turn signals do not work or blink or click. Bulbs replaced, fuse replaced, flasher, and turn signal switch. The hazard lights work. My high beams come on when I pull the switch towards me until I release it, as it should. But when I push the lever and it clicks in place the high beams do not come or stay on as they should. The indication light on the dashboard does not come on either. I'm guessing these two are linked
Do you
have the same problem?
Yes
No
Thursday, August 15th, 2013 AT 4:09 PM

17 Replies

Tiny
KEN
  • ADMIN
It looks like you have lost power going to the system, here is a wiring diagram and a guide that will help you see what the problem is.

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

Please let us know what happens so it will help others.

Cheers, Ken
Was this
answer
helpful?
Yes
No
+2
Friday, September 8th, 2017 AT 1:23 PM
Tiny
JAMESBENNETT1
  • MEMBER
  • 1999 MERCURY COUGAR
  • 200,000 MILES
Turn signals/hazard lights stopped working. They were working on and off during the couple of months and finally stopped working completely. The fuse inside the car is not blown.

1999 Cougar V6

Thanks, Ken.
Was this
answer
helpful?
Yes
No
Friday, September 8th, 2017 AT 1:24 PM (Merged)
Tiny
HMAC300
  • EXPERT
Check your flasher first Flasher is located on the signal light switch, at the rear next to lever, remove lower column cover and on the signal switch next to the lever you will see flasher plugs right into switch.
Was this
answer
helpful?
Yes
No
-1
Friday, September 8th, 2017 AT 1:24 PM (Merged)
Tiny
LISA_AFFOLTER
  • MEMBER
  • 1999 MERCURY COUGAR
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 108,000 MILES
Electrical problem
1999 Mercury Cougar 6 cyl Front Wheel Drive Automatic 108000 miles

around 2 weeks ago my turn signals were going out periodically. Now both my turn signals and hazards arent working. Its not the fuse or bulbs. Any advice wuld be greatly appreciated.
Was this
answer
helpful?
Yes
No
+1
Friday, September 8th, 2017 AT 1:24 PM (Merged)
Tiny
DOCFIXIT
  • EXPERT
Maybe turn signal flasher located on top of steering column should be round plastic might be blue
replace Hope this will help
Was this
answer
helpful?
Yes
No
+1
Friday, September 8th, 2017 AT 1:24 PM (Merged)
Tiny
PORTAGEWICCAN
  • MEMBER
  • 1999 MERCURY COUGARMERCURY COUGAR
I have a 1992 mercury cougar ls 3.8 engine. The hazards, brights, and windshield wipers all work but no turn signals. I changed the switch, the fuse in the fuse box, and the relay on the right side of the column. Is there another relay or fuse I am missing or what else can I do?
Was this
answer
helpful?
Yes
No
Friday, September 8th, 2017 AT 1:24 PM (Merged)
Tiny
RASMATAZ
  • MEMBER
Look below is this the one you checked the electronic flasher


http://www.2carpros.com/forum/automotive_pictures/12900_flasher_1.jpg



www.eautorepair.net
Was this
answer
helpful?
Yes
No
Friday, September 8th, 2017 AT 1:24 PM (Merged)
Tiny
PORTAGEWICCAN
  • MEMBER
From what I can see from small picture yes that is the one I changed
Was this
answer
helpful?
Yes
No
+1
Friday, September 8th, 2017 AT 1:24 PM (Merged)
Tiny
SSPRINT
  • MEMBER
  • 1996 MERCURY COUGAR
  • V8
  • 2WD
  • AUTOMATIC
  • 124,000 MILES
Electrical problem
1996 Mercury Cougar V8 Two Wheel Drive Automatic 124000 miles

The turn signals and brake lights won't work. I have checked the bulbs and the fuses under dash. The third brake light in rear windo does work. All other electrical seems to be fine. Any ideas.

Thanks in advance for any help.
Mike Skinner
Was this
answer
helpful?
Yes
No
+1
Friday, September 8th, 2017 AT 1:24 PM (Merged)
Tiny
JACK42
  • MEMBER
The brake lights go through the turn signals, since the 3rd light works, im gonna say that you have a bad turn signal switch
Was this
answer
helpful?
Yes
No
Friday, September 8th, 2017 AT 1:24 PM (Merged)
Tiny
SSPRINT
  • MEMBER
Went to junk yard and pulled one from 96 T-Bird. Works fine. Thanks

Mike
Was this
answer
helpful?
Yes
No
Friday, September 8th, 2017 AT 1:24 PM (Merged)
Tiny
KAYTLEN17
  • MEMBER
  • 1997 MERCURY COUGAR
  • 4 CYL
  • FWD
  • AUTOMATIC
  • 220,000 MILES
Electrical problem
1997 Mercury Cougar 4 cyl Front Wheel Drive Automatic 220000 miles

Suddenly my turn signals are not working. This happened soon after I replaced a blue 20 fuse under the hood. The signals make no noise whatsoever, and nothing lights up in the dash. The hazards arent working either. Occasionally, when I start my car, I hear a buzzing sound that sounds electrical. It sounds like it's coming from the dash on the front driver side. It seems to be coming from inside or under the dash.
Was this
answer
helpful?
Yes
No
Friday, September 8th, 2017 AT 1:24 PM (Merged)
Tiny
BLUELIGHTNIN6
  • EXPERT
Suspect faulty electronic flasher unit, located behind dash to the left of the steering column
Was this
answer
helpful?
Yes
No
Friday, September 8th, 2017 AT 1:24 PM (Merged)
Tiny
ELOPEZ
  • MEMBER
  • 2002 MERCURY COUGAR
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 200,000 MILES
Electrical problem
2002 Mercury Cougar 6 cyl Front Wheel Drive Automatic 200000 miles

when engaged the turning lights do not work the blinking arrows do not show and lights do not show on either the front or rear of car also my emergency lights dont work clicking sound heard but again arrows dont show inside of car or outside
Was this
answer
helpful?
Yes
No
Friday, September 8th, 2017 AT 1:24 PM (Merged)
Tiny
RASMATAZ
  • MEMBER
Check the Turn Signal Relay On top of steering column.
Was this
answer
helpful?
Yes
No
-1
Friday, September 8th, 2017 AT 1:24 PM (Merged)
Tiny
BRT52670
  • MEMBER
  • 1997 MERCURY COUGAR
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 110,000 MILES
Electrical problem
1997 Mercury Cougar 6 cyl Two Wheel Drive Automatic 110000 miles

Well first the turn signals stopped working. Checked the fuses and the bulbs. All is ok. Then the headlights and the wiper blades stopped working. Don't know what to do or how to fix it. Please help. Sorry. I'm pretty broke so I can't pay for an answer.
Was this
answer
helpful?
Yes
No
Friday, September 8th, 2017 AT 1:24 PM (Merged)
Tiny
BLUELIGHTNIN6
  • EXPERT
Suspect faulty multifunction switch. This is the switch used to operate the signals, wipers etc.
Was this
answer
helpful?
Yes
No
Friday, September 8th, 2017 AT 1:24 PM (Merged)

Please login or register to post a reply.

Recommended Guides