"misfire" codes keep coming back and engine will run rough.

Tiny
DBATCH
  • 1999 KIA SPORTAGE
  • 95,000 MILES

Replaced spark plugs, both coil packs, and o2 sensors. Upon start up, car will run fine for a few seconds, then start to run rough. Scan and will get either #2 or #4 cyl. Misfire code.

Do you
have the same problem?
Yes
No
Thursday, June 7th, 2012 AT 12:30 AM

5 Replies

Tiny
SATURNTECH9
  • EXPERT
  • 30,641 POSTS

Have you checked compression yet?

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Thursday, June 7th, 2012 AT 1:14 AM
Tiny
DBATCH
  • MEMBER

Checked compression, average is about 105 on each cyl. But I dont know what would be a good compression.

Was this
answer
helpful?
Yes
No
Sunday, June 10th, 2012 AT 1:13 PM
Tiny
SATURNTECH9
  • EXPERT
  • 30,641 POSTS

You have the 2.0L engine?If so it says compression is 188psi so that would be pretty low compression.

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Monday, June 11th, 2012 AT 7:16 PM
Tiny
DBATCH
  • MEMBER

Should I find a used head or have this one redone, problem is kind of short on cash. I had to replace the exhaust manifold, it was cracked in two spots about 3" long.

Was this
answer
helpful?
Yes
No
Monday, June 11th, 2012 AT 9:36 PM
Tiny
SATURNTECH9
  • EXPERT
  • 30,641 POSTS

Since the compression is low across all the cylinders I would check the cam timing.

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Tuesday, June 12th, 2012 AT 1:05 AM

Please login or register to post a reply.

Related Engine Runs Rough Questions

Help us by donating