1999 Chevrolet Tahoe headlights windsheild wipers

Tiny
DOUG BRUCE
  • MEMBER
  • 1999 CHEVROLET TAHOE
  • 225,000 MILES
I start the truck and the headlight come on.I was driving and I turn the lights on and the lights turned off so I pulled over turned the switch one spot back the lights come on but no high beam.I continue driving then pull over in a better spot turn the light switch off and on 2 times and the headlights start working. Not shure what happened there then the wipers were on intermint and the wipers start going all the way on so I turned them off and they kept going.I turned them on and off 3 times and the wipers went back to normal. Its been 2 days and it seems to be working normaly but I have noticed the wipers for some time when on intermitly the wipe 2 times for no reason then go back to normal. Not shure what to check
Do you
have the same problem?
Yes
No
Thursday, November 14th, 2013 AT 11:50 AM

1 Reply

Tiny
HMAC300
  • EXPERT
The headlights will come on when the switch is on automatic and the light sensor thinks it's darke enough for it. If you had something on the dash that is why it may have slid over the sensor. When on auto and you turn them on theywill go off, screwy way to do it but it does. For no high beam check fuses and relays underhood fuse box. For wipers you'll have to check the sitch or it may be the circuit board in wiper motor.
Was this
answer
helpful?
Yes
No
Thursday, November 14th, 2013 AT 12:00 PM

Please login or register to post a reply.

Sponsored links