I was driving today, stopped at a store.

Tiny
SHOCKRIM
  • 1998 OLDSMOBILE ACHIEVA
  • 190,000 MILES

HI, I was driving today, stopped at a store when I started it and the car devoloped a "misfire". I stopped at 2 auto stores to pull the codes since the check engine light was flashing. Both places could not read anything from the ecu. I put injector cleaner and gas in. Ran it for 12 miles back home with no change. I am open to ideas on how to get the codes from the ecu or to fix it. Thanks, Brian

Do you
have the same problem?
Yes
No
Saturday, November 24th, 2012 AT 7:41 PM

4 Replies

Tiny
JDL
  • EXPERT
  • 16,281 POSTS

Did they use a scanner that shows live engine data or just tried to read codes? Does pin 16 at the datalink connmector have voltage? Pins 4 and 5 are grounds.

Was this
answer
helpful?
Yes
No
Saturday, November 24th, 2012 AT 7:50 PM
Tiny
SHOCKRIM
  • MEMBER

Hi, thanks for the quick reply. They used a live engine data reader. It powers up the scanner then it powers down the scanner before it gets the chance to read it.

Was this
answer
helpful?
Yes
No
Saturday, November 24th, 2012 AT 8:06 PM
Tiny
SHOCKRIM
  • MEMBER

Hi again. I decided to look at the spark plugs, found them worn and out of gap. So I cleaned and set the gap. Runs like new again. Still dont know why the ecu wont read.

Was this
answer
helpful?
Yes
No
Saturday, November 24th, 2012 AT 10:00 PM
Tiny
JDL
  • EXPERT
  • 16,281 POSTS

Glad you got it fixed. Not sure about datalink connector? Sounds like it may be losing voltage or ground?

Was this
answer
helpful?
Yes
No
Sunday, November 25th, 2012 AT 2:39 PM

Please login or register to post a reply.

Other Check Engine Soon Light Questions